Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
I was on a 300 mile trip last friday, and at about the 150 mile mark, the engine suddenly lost power, (heat and oil pressure were good). I managed to limp along for a few miles to a place off of the freeway.

When I stopped, the engine was running like a perfect 4 cylinder. I unhooked the Edge with Attitude, and the truck started up and ran perfect. 20 miles down the road it started doing the same thing. Limped it up to the next town (40 miles @ about 30 mph average) and ended up leaving it there.

Picked it up on a trailer yesterday to bring it home to finish taking the Edge off before taking the truck to the dealer.

Has anyone else had a 4 cyl D/M? , and if so what was the problem?

Oh, it is a 2005, with 44,000 miles on it.

Thanks in advance for your help.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #2 ·
I was on a 300 mile trip last friday, and at about the 150 mile mark, the engine suddenly lost power, (heat and oil pressure were good). I managed to limp along for a few miles to a place off of the freeway.

When I stopped, the engine was running like a perfect 4 cylinder. I unhooked the Edge with Attitude, and the truck started up and ran perfect. 20 miles down the road it started doing the same thing. Limped it up to the next town (40 miles @ about 30 mph average) and ended up leaving it there.

Picked it up on a trailer yesterday to bring it home to finish taking the Edge off before taking the truck to the dealer.

Has anyone else had a 4 cyl D/M? , and if so what was the problem?

Oh, it is a 2005, with 44,000 miles on it.

Thanks in advance for your help.
Nothing similar???
 

·
Registered
Joined
·
352 Posts
Patience My freind you will be helped soon. My guess witch isnt much is that it was putting its self in to a limp mode for somereason.
 

·
Administrator
Joined
·
8,815 Posts
When was the last time you changed you fuel filter? Last time you filled up? Any check engine lights? Were you limited to a certain RPM? Just felt like no power? Could you hear the turbo spooling? Just some things that I can think of to ask. I haven't heard of the same thing you are talking about though.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
When was the last time you changed you fuel filter? Last time you filled up? Any check engine lights? Were you limited to a certain RPM? Just felt like no power? Could you hear the turbo spooling? Just some things that I can think of to ask. I haven't heard of the same thing you are talking about though.
I had filled up a couple of days prior to starting the trip, probably about 250 miles on the tank at the time of the incident, it for sure was not a fuel filter issue, I know what that feels like.:)

The turbo was making a little boost acording to the edge programer, I could not really hear it, but the engine was so cut back I really would not expect to hear it though.

I did have a check engine light consistently after the first "restart" and thereafter. Rpm would only go to about 2,000 under the best circumstances, power output was dismal, with a top speed of about 42 (down hill), cut back to 11 up the exit ramp!

It is strange, it is like one side of the engine was fireing, but not the other, the truck seemed to be firing evenly, but only on 4 cyl. Kind of sounded like a John Deere backhoe, and it would drive nearly as fast as a backhoe!:rof

The engine evened out twice and ran fine twice for about 20 miles the first time, and about 15 miles the second time, so I am prone to believe that the problem is an electrical issue, and not a mechanical issue, but who knows?

The truck is at the dealer now, waiting to hear from them soon I hope!!
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #6 ·
Update - Dealer called just now and informed me that the problem was with a fuel injection wiring harness, and that there is a service bulitin issued dealing with this issue.

I don't have any more information that is more specific to this problem yet. The truck should be repaired Monday afternoon and I will post more info if I am given more info.

The diesel waranty will cover it, but it will cost me $100.00!
 
1 - 6 of 6 Posts
Top