Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Oh...... Squirrel!
Joined
·
24,083 Posts
Discussion Starter · #1 ·
My dad owns a auto repair buisness and I own a small towing co. I was suppose to start late today and a customer broke down on a main road. Well my dad told our manager to go get the car (Now I own and drive all the trucks and tow everything myself) So he jumps in it and takes off (without letting it warm up im sure) he gets about 1/8 mile away and goes to pull out on the road and he said the truck made a noise and there was no oil pressure. So he coasted it down the road to a gas station pulled over and called my dad. It still runs so dad tells him its probably the sending unit so just come back :mad: :mad: :mad: :mad: . Well 1/8 mile from the gas station the motor locked up.

We pulled it in the shop and replaced all the bearings (only 1 was bad) and the oil pump. Now we crank it and it doesnt have oil pressure not a drop comming out of the block where the filter goes....... Any ideas?

Its a 1994 3500HD with a 6.5 Motor. Motor was replaced 150,000 miles ago before I owned it... Still relativly strong.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts
Discussion Starter · #2 ·
We took the oil pan back off after I posted this and pulled the drive shaft that turns the pump. Its shaped like a alan key and the corners on the top where it goes into the motor were striped. My buddys 6.5 burban was torn apart there so we "borrowed" the shaft :eek: started it and still no pressure. So we took the pump driver out on the top of the motor that connects the cam shaft to the shaft that drives the pump and the gear was badly worn. Back to the burban! We got the part cranked it and oil started comming out of were the oil filter goes so we installed the filter and started it. It was real rough the first few seconds then went away. I drove it down the road and the idle went low like it was gonna shut off. I hit the throttle and the RPM's raised then it was fine. Ill have to tow tomorrow to see if it will be ok.:cool:



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
262 Posts
my dad had a 94 suburban with teh 6.5l and it had a problem wiht alternators and fuel pumps and lost the motor at 95000 miles and got replaced before the 100000 mile warranty but nothing of this sort
 
1 - 3 of 3 Posts
Top