Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Need some help here. I have a 93 k 2500 5.7 tbi and it hesitates when you press on the accelerator lightly. No hesitatin at all when accelerating hard. Also when engine is cold it misses and carrys on if i lightly press on the accelerator seams to clear right up if i press harder on the gas. Relaced tps sensor and cap and rotor. What should be my next move ? Thanks
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
162 Posts
I had a '95 years ago...when through 3 pumps before I sold it. It was doing the same thing you desribed. One pump only lasted a month!
 

·
Registered
Joined
·
1,068 Posts
Worked on a 97 for a year that had a hesitation replaced everything cap rotor plugs blah blah blah........ finally found out the cap that i put on was messed up...... it wasn't made right from the factory....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I think im going to replace the cap and rotor again. The last time i replaced the cap and rotor it was hesitating and replacing the cap and rotor cleared it right up. I just thought i would have got more mileage out of the cap and rotor.
 

·
Registered
Joined
·
349 Posts
A faulty coolant temp sensor will do funny things to a tbi. Remember, you truck has two of them, one for the dash and one for the ecm. They usually dont idle worth a sh!t when they are going bad, had a few that the rpms would go up and down at idle till it eventually would die. Replaced the coolant temp sensor and ran like a champ, still does.

One for the ecm is up at the thermostat.

Edit---- Wow just realized i opened up an old thread......
 
1 - 8 of 8 Posts
Top