Chevy and GMC Duramax Diesel Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
During the last snow storm, my ABS light came on. I pulled codes from the computer and there were no codes at all.

Any help on what direction to start is appreciated. I am wondering abotu speed sensors / maybe a wire was broken during the storm.

Thanks for all the help.
 

· Premium Member
Joined
·
9,509 Posts
also, were you spinning your tires a lot? It will do that if it sees your tires are spinning for a long time...i have gotten mine to come on when playing around on ice. If its still not on, dont worry about it.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
It was in four wheel but I was not spinning a lot. It has gone off a few times but it comes back on pretty quickly.

I did replace the wheel bearings in the front not too long ago. So I would hope it is not the hub assembly.

Is there a speed sensor in the rear?
 

· Registered
Joined
·
356 Posts
I don't think there is one in the rear, but I'm not positive.
I would check the sensors on the wheel bearings, make sure they didn't come loose from either the bearing, or the connection on the frame. Also Check to make sure the wire didn't rub through somewhere. If it got routed wrong when you changed the bearings, it mave have either got pinched or rubbed against the tire and broken the wire.
 

· Premium Member
Joined
·
9,509 Posts
where did you get the hub? If you didnt get a timken or an OEM one, it is most likely the speed sensor on that side. Also look at the wiring really closely on the truck side. had a problem with the ex-wife's car and the wiring was screwed up...not the sensor.
 

· Banned
Joined
·
24,781 Posts
Its probably one of your wheel speed sensors. Take it to a repair shop with a scanner. They can read the bcm to see whats wrong with it as well as drive it to see if a sensor is off. Shouldnt be bad. All the ABS light means is the ABS isnt working right now :cool:



 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top