Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
292 Posts
Discussion Starter #1
And so it starts with a new issue...

On my way into work the other day my DIC displayed "SERVICE AIR BAG" then disappeared. When I went home, no issue, Next drive, "SERVICE AIR BAG". Both times, no air bag light illumination and the message disappeared by itself in less than a minute.

However, today the message came on and stayed on, and so did the light. Any clue what may be causing this (besides a faulty system obviously) and what may fix it? Thanks!
 

·
Registered
Joined
·
292 Posts
Discussion Starter #2
bump?
 

·
Registered
Joined
·
553 Posts
need to get it scanned , but if i was a betting man it is going to be a front impack sensor under core surport .
 

·
Registered
Joined
·
41 Posts
Hey Spacecase,
Have you found out what caused your service airbag light to come on? Mine just did the same thing.

Thanks
 

·
born country
Joined
·
2,427 Posts
sub'd for future problem solving. (hopefully not lol)
 

·
Registered
Joined
·
292 Posts
Discussion Starter #6
The Solution!!

OK well the solution to my problem was a faulty left side air bag sensor... total parts cost of $117.21 plus labor (about 1 hour at $90.97 per hour) at the dealer...yes I could have done it myself but the truck was covered under an extended warranty.

I highly suggest just ordering the part...they made a huge fuss about doing it...the sensor isn't really that hard to reach.

Mine was also compounded by a broken clock spring (the piece that makes your steering wheel controls and air bag work so you don't twist the wires as you turn the wheel). Hopefully that isn't the broken part for you...that is a $421.77 part!

Total cost for parts and labor on that shot...$711.82!
 

·
Registered
Joined
·
41 Posts
Thanks much for the reply. I think I will at minimum look into finding the problem myself. All I can do is check for faulty grounds and connections. I'm concerned about blowing the darn airbags. You mention left airbag sensor. Are you refering to the sensor out front near the bumper? The location of that sensor you mentioned would be a great help.

Thanks,
Andrew
 
1 - 7 of 7 Posts
Top