Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I've got an '07 LBZ. Only had it maybe a month or so now and got into it this morning and after starting noticed that the volt meter on the dash showed 12 volts. After 30 seconds or so it slowly rocked itself up to 14-14.2 volts. Drove to work, let it sit most of the day and took a volt meter out to check the battery. Battery shows 12.8 volts. Start up... battery shows 12.2 volts. After 30 seconds or so voltage at the battery slowly climbs to 14.2 volts. Sounds to me that the voltage regulator is flaking out but.... In this day and age of computer controls I didn't know if there is some sort of slow start up program installed. Otherwise it's of to the parts store. Thanks for the help.
 

·
Registered
Joined
·
103 Posts
Mine does the same thing.
I read somewhere on here that the glow plugs continue to draw a heavy load after starting, that's why it is low at first.
 

·
Registered
Joined
·
589 Posts
mine wont start at all! batteries both charged, and alternator checks out perfect...
 

·
Premium Member
Joined
·
17,806 Posts
I've got an '07 LBZ. Only had it maybe a month or so now and got into it this morning and after starting noticed that the volt meter on the dash showed 12 volts. After 30 seconds or so it slowly rocked itself up to 14-14.2 volts. Drove to work, let it sit most of the day and took a volt meter out to check the battery. Battery shows 12.8 volts. Start up... battery shows 12.2 volts. After 30 seconds or so voltage at the battery slowly climbs to 14.2 volts. Sounds to me that the voltage regulator is flaking out but.... In this day and age of computer controls I didn't know if there is some sort of slow start up program installed. Otherwise it's of to the parts store. Thanks for the help.
The starter and the glow plugs use lots of amps during first start-- that is why it shows 12 volts. If it slowly go up to 14 volts, everything is normal.
 

·
Registered
Joined
·
33 Posts
mine does that if i dont let the engine warm up for acouple of minutes before i operate the truck. it is fine after that
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
Thanks Fellas! You know how you make a big purchase and everything seems to go to holy hell afterwards... I'm glad this is normal! Thanks again.
 
1 - 6 of 6 Posts
Top