Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·

·
Registered
Joined
·
7,819 Posts
wow that sounds pretty awful. bump for you. not sure what that could be
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
I forgot to mention this is not at idle the video was at about 1400rpms. It seems to follow the rpms. I'm not sure what it could be


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
I'm thinking bad injectors too I'm gonna see if I can get a tech 2 or something to get it figured out. Anybody else have any ways I can get them checked out?


Sent from my Autoguide iPhone app
 

·
BAD ASS LBZ that is
Joined
·
633 Posts
the noise you described in the intake sounds like it could be in need of valve adjustment or maybe a injector not seated in the injector cup properley and is blowing compression around the injector.

Is it a stock motor? stock fueling?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
Ya it's a stock motor pretty much. Just installed a quadzilla stealth 2 the other day just to get readings. But other than that and a banks exhaust that's it.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
578 Posts
another bump. Mind sounds like that, but not quite as loud. I have noticed it gets worse under load and towards the end of an oil change.

Hope you figure it out.
 

·
Premium Member
Joined
·
516 Posts
How old is the fuel filter/oil and filter? It may need to just be serviced. Mines gets cranky when she needs stuff lol
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
Just had oil changed and filter but you never know it could be the simplest of things. It's basically a really loud tick when under load and not as bad when idle. There's no metal in the oil and doesn't seem to have any fuel in it and no smoke out the exhaust so it cant be bad injectors can it?


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
116 Posts
Has a solution been found? I'm having the exact same sound on my '03 LB7.
 

·
Registered
Joined
·
344 Posts
yes it still can. I had no smoke, no fuel in oil and still had a bad injectors.
X2. I had zero signs just bad balance rates
 

·
Registered
Joined
·
5,483 Posts
That's sounds horrible it sounds like one of your injectors are bad.
 
1 - 16 of 16 Posts
Top