Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
Anybody had any problems with Banks causing trouble codes? I have had some issues with DTC's. Some MAF codes but others like no communication with ECM and TCM. Could MAF problems cause errors like "No communication with TCM or ECM?" or could it be my tuner? I cleaned the MAF today and have had the Banks turned down to stock. Has anyone had a bad experience with Banks tuners?:help
 

·
Registered
Joined
·
457 Posts
I had an issue when I first bought my Economind. While towing it would say the tranny was slipping really bad! I knew it wasn't the tranny, since the truck had 5,000 miles on it. It would throw the code then return the truck to stock. I couldn't clear the code.. After messing with it for a while it finally cleared then did it again on the flats at 55mph... I called Banks and wanted a replacement programmer! They tried to tell me I was running the tuner too high! Funny stuff... since they built the economind for towing and you can run at any level with it!! I did get them to replace the Economind and have not had a single issue since! Really like the tuner and guages! Could your issues be from stacking the two tuners??? Not sure about stacking them. Later Dave
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
I dont think its from the tuners. The Quad is just set to stock with DPF off. And this trouble started before the quad was put on it.
 

·
Registered
Joined
·
457 Posts
Take them off and see if does it still.. I don't think the MAS would be the problem. Banks has a great intake. I have had problems with AFE but not Banks..
 
1 - 4 of 4 Posts
Top