Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I installed a Banks Six Gun on my 2005 LLY.
Under moderate acceleration the truck will hesitate or buck 2-3 times
when it shifts into overdrive. My main concern is I hope it is not damaging
my engine or turbo when this happens.
Has anybody else had this happen?
 

·
Registered
Joined
·
276 Posts
Have you contacted Banks yet to see what's up? Sometimes there are errors in the software with the chip you buy. Most of the time you can exchange it or send it back for a fix.
 

·
Administrator
Joined
·
8,808 Posts
What power setting are you running? Please define moderate acceleration. I wouldn't worry about your engine or turbo, but your tranny is a different story. If you are running a higher power setting and pushing it to merge into traffic, you could limp your tranny when it shifts into 5th. When was the last time you changed your fuel filter?? Could be starving the truck of fuel, but I would think you would get a check engine light, but not always.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,163 Posts
COuld also be turbo bark,Which is real bad for the turbo, pretty comon on the lly when the egr is not blocked under high boost shifts.

DOse it sound like the turbo is chirping at all when it dose it?
 

·
Registered
Joined
·
29 Posts
Hmmm...

I would recommend updating some of the parts on your truck before trying to max it out with the cheapest possible method, ie.programmer. You can add extremely functional and lasting power through intake, exhaust, torque converter, and intercooler upgrades. Definitely consider adding aftermarket head studs too before getting your boost pressure too high. Its fun to roast your tires(for under $1000) at a stop light until you realize you are taking years of reliability off of your truck by not updating parts on your truck not engineered for such abuse. If you have the money to throw away, you might as well spend it on the upgrades instead of on a new truck/engine/transmission.
 

·
Registered
Joined
·
150 Posts
Very true on the last statement.

Check your fuel filter for one.

I have the six gun and banks intake and scoupe on my dads LLY and no probs i can only go to setting 5 tho no EGT probe yet.
 
1 - 6 of 6 Posts
Top