Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
525 Posts
Discussion Starter · #1 ·
On my 04 lly when I turn on the right blinker, the hazards flash (left and right blinker). The left blinker works fine, but the right does this more often than not. It makes no difference if the running/head lights are on or off. All the bulbs are good, none burned out. Any ideas on where to look? Thanks.
 

·
Registered
Joined
·
30 Posts
Sounds like there is a short somewhere, I'd start with the trailer harness plug in. I have had issues with mine in the past, but I tow pretty regular so my plug in gets a lot of use....
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #3 ·
I will check it out. I last hooked to a trailer a week ago.
Thanks.
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #4 ·
I just checked the trailer plug under the cover, unplugged where the wires feed in, and there is something on the cross member back there with 4 plugs on it. They all look good with no signs of corrosion.
 

·
Registered
Joined
·
30 Posts
It was worth a shot, maybe someone else will have some ideas....
 

·
Registered
Joined
·
307 Posts
Replace all the bulbs. It's cheap and then you know they are all good. Here's why.

Years ago I also had really weird things happening when I turned my right side blinkers on. Spent alot of time trying to figure it out. I knew there was a short somewhere but where?

Turns out the brake bulb looked perfect when not in use, but put power to it and the filiment would bend and touch the other one and stay connected for a few moments giving me a short. It then cooled off and bent back to where it looked normal.

Crazy.
 

·
Registered
Joined
·
30 Posts

·
Registered
Joined
·
7,833 Posts
Unplug those 4 plugs under the rear of the truck. Clean them with electrial cleaner then put some die electric grease on them and reconnect. Also remove your dash panel below the sterlering wheel. There is a blinker/flasher module in there that controls it.

Mine just did this 3 weeks ago. Pulled module and cleaned the prongs with a soft bristle brass brush and it fixed it
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #9 · (Edited)
Just to update this, the problem was a bad flasher module (10 pin). It was $30 at Napa

Thanks for the help.
 
1 - 10 of 10 Posts
Top