Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
just spent a bunch of money getting injectors and cp3 and lines, get my pick up back and next day p0089 p0571 get thrown on cts.. blinkers work until i press the break cruise control works until i use turn signal reverse lights work until i hit break third break light works. cd player wont load or eject my cds. hazards work fine w/ break depressed. sick of working on this thing especially when it comes home from the shop the last thing i want to do is wrench on it when it comes back... flustered checked fuses unplugged break controller checked all bulbs checked the two grounds i know of.. could be mfs? going back to check for shorted out wires in the harness but not an electrician so not even sure what i can do with the wires on this thing. might as well be a motor wrapped in fiberoptic cable to me.
 

·
Registered
Joined
·
4,954 Posts
just spent a bunch of money getting injectors and cp3 and lines, get my pick up back and next day p0089 p0571 get thrown on cts.. blinkers work until i press the break cruise control works until i use turn signal reverse lights work until i hit break third break light works. cd player wont load or eject my cds. hazards work fine w/ break depressed. sick of working on this thing especially when it comes home from the shop the last thing i want to do is wrench on it when it comes back... flustered checked fuses unplugged break controller checked all bulbs checked the two grounds i know of.. could be mfs? going back to check for shorted out wires in the harness but not an electrician so not even sure what i can do with the wires on this thing. might as well be a motor wrapped in fiberoptic cable to me.

if they pulled the engine or cab to do the work i would check this ground here (just to the left of the cliford siren), when i had my head gaskets replaced this ground was not reconnected, i had most of the problems you do and more and ended up toasting a couple modules. there should be a ground strap from that post to the back of the engine block that grounds the firewall (and the components in the truck that ground to that, light switch, cluster, transfer case computer radio ect)


 

·
Registered
Joined
·
4,954 Posts
its 2, the original factory braided cable was never put back on so i ran my own 0 gauge ground to the post, it basically runs from 1 - battery post to the other and just connects there in the middle to ground the fire wall, then i grounded the engine block with 0 gauge to the batteyr - also and ran some 0 down to the frame for good measure.
 

·
Registered
Joined
·
4,954 Posts
see the braided ground wire behind the AC compressor lines? thats what i was missing, so i replaced it with 0 gauge (that braided wire is a bit insufficient any way, like every other ground on this truck)




man i wish my truck was this clean.....
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
roger. yeah the factory braid is hooked up and tight i installed fass 150 and double checked that ground its hooked up and tight. also the controller j box above the spare tire checked that its clean and not corroded.. he did pull the cab and i know there is more grounds in the front clip but i don't know where there at and i don't want to pull that thing off.. since its sunday and i have to work tomorrow. haha mfs?
 

·
Registered
Joined
·
4,954 Posts
roger. yeah the factory braid is hooked up and tight i installed fass 150 and double checked that ground its hooked up and tight. also the controller j box above the spare tire checked that its clean and not corroded.. he did pull the cab and i know there is more grounds in the front clip but i don't know where there at and i don't want to pull that thing off.. since its sunday and i have to work tomorrow. haha mfs?
there should be a frame ground under the driver seat also, my guess is that you are missing a ground connection to the tail lights, one of the 3 wires in the bulb harness should be a ground. to avoide these problems i did a big 3 on each battery so the factory grounds are irrelevant, i recommend doing the same to anyone that owns a chevy truck, especially from the 01 02 erra since there grounds seem to be even worse, it wont hurt you any to do it besides an hour of your time and 50-100 bucks or so in wire, which at least for me is nothing to give me the peace of mind that the factory ground problems will plague me no more.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top