Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 20 of 32 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 · (Edited)
having a problem with light blue smoke at idle and heavy blue smoke on acceleration with it clearing away at cruse speed some say it is valve guides but upon going to the dealer the claim there are no valve guide seals on the duramax 6.6 and that that problem could be turbo seals anyone with any ideas? this is a 2002 silverado 6.6 LB7
 

·
Registered
Joined
·
172 Posts
having a problem with light blue smoke at idle and heavy blue smoke on acceleration with it clearing away at cruse speed some say it is valve guides but upon going to the dealer the claim there are no valve guide seals on the duramax 6.6 and that that problem could be turbo seals anyone with any ideas? this is a 2002 silverado 6.6 LB7

my buddies ford does this.......and tis been in and out of the dealer 4 times and they still cant fix it.............but it sounds like turbo seals.
 

·
Registered
Joined
·
17 Posts
Same thing here just last week. Changed the fuel filter and all was clear.
12,000 miles on that filter, cut it open and dirty for sure
 

·
Registered
Joined
·
181 Posts
There were lots of problems with the seals on the injectors and the injection pump on the LB7 motors. Most of the problems cleared up by the middle of 2003, but some still had the problems. What is your oil level like? If your engine seems to be making oil (oil level rising) it will most likely be the injectors or the pump leaking fuel into the crank case. You can probably tell by the smell of the smoke as well. Oil smoke and fuel smoke have fairly different smells.
 

·
Registered
Joined
·
2 Posts
I have the same problem with my 03 silverado 2500hd. I havent lost any water or gained any oil and mine is running smooth as a diesel runs. My exhaust smells of raw fuel. Mine seems to be more like it is loading up but I am not for sure. I have had it in the shop and they cant find anything wrong. THIS IS MY FIRST DIESEL and other than that I am VERY PLEASED with mine.
 

·
Registered
Joined
·
678 Posts
having a problem with light blue smoke at idle and heavy blue smoke on acceleration with it clearing away at cruse speed some say it is valve guides but upon going to the dealer the claim there are no valve guide seals on the duramax 6.6 and that that problem could be turbo seals anyone with any ideas? this is a 2002 silverado 6.6 LB7
Chances are that it's injectors.
 

·
Registered
Joined
·
872 Posts
bringing this back from the dead as i am having very familiar problems. was the issue resolved and if so what was it?
 

·
Stupid Has The Balls
Joined
·
2,515 Posts
Have the balance rates checked out on your injectors.
 

·
Registered
Joined
·
872 Posts
i did. they are all less then +/- 1.2 is both park and drive. no fuel in oil. only burns oil when engine is cold. after it warms up it only smokes when i really get on it. thanks
 

·
Stupid Has The Balls
Joined
·
2,515 Posts
Kinda sounds like rings
 

·
Registered
Joined
·
872 Posts
checked compression and it was good. i found the cylinder that is smoking. it is the furthest back on the driver side, i think its cylinder 7.
 

·
Stupid Has The Balls
Joined
·
2,515 Posts
Bump for an answer
 

·
Registered
Joined
·
43 Posts
Same problem here just smokes blue at idle then after a few minutes of driving it clears up and is gone. Fuel milage is around 19mpg and getting 600km per tank in city with 95 lts of fuel and 750-800km highway. I have not found any fuel in oil at all ever. Truck has been into two different dealers they say injectors are good but there are a 3 injectors that are on the high side but still inside there specs. Any ideas? Fuel filter has around 23,000 km on it gonna change it to see if it does anything can hurt. Any suggestions?
 

·
Registered
Joined
·
4,743 Posts
I have same prob just got truck back from getting valve seals done ... That didn't fix my prob ..back to the shop
 

·
it stinks and whistles :)
Joined
·
5,349 Posts
Same problem here just smokes blue at idle then after a few minutes of driving it clears up and is gone. Fuel milage is around 19mpg and getting 600km per tank in city with 95 lts of fuel and 750-800km highway. I have not found any fuel in oil at all ever. Truck has been into two different dealers they say injectors are good but there are a 3 injectors that are on the high side but still inside there specs. Any ideas? Fuel filter has around 23,000 km on it gonna change it to see if it does anything can hurt. Any suggestions?
After 23000 miles, change your fuel finger anyway


Sent from my Autoguide iPhone app while doobin a smokie
 

·
Registered
Joined
·
924 Posts
mine does the same thing and i was hoping it would clear up with the extra filtration of the airdog, but it hasnt. My rates are within specs. I was told its either gonna be the injector body cracked or the injector cups not seated, either way its gonna be injector related.
 

·
Registered
Joined
·
217 Posts
mine does the same thing and i was hoping it would clear up with the extra filtration of the airdog, but it hasnt. My rates are within specs. I was told its either gonna be the injector body cracked or the injector cups not seated, either way its gonna be injector related.
Mine also does the same an Friday I was told this exact same thing...


Sent from my Autoguide iPhone while hiding at work...
 

·
Registered
Joined
·
139 Posts
Same here. LBZ
light blue smoke at idle and guys behind me say it puffs a lil blue smoke before turning into black when i romp on it.
Balance rates are ok, no fuel in the oil.
I figure its just cause i'm putting more fuel to it. I haven't been too concerned about it
 
1 - 20 of 32 Posts
Top