Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 4 of 4 Posts

Registered
Joined
96 Posts
Discussion Starter · #1 ·
I have a older brake controller in my truck that didnt work. I pulled it out and hooked the red wire up to the positive and the blue to the negative posts on a battery and it lit up. When its plugged in my truck it doesnt do anything so i did some digging. I checked the fuses, the manual says there is a fuse labeled etc/ebc the ebc is for electronic brake controller so i thought this was the fuse. Pulled the fuse cover off and there was no fuse, im thinking cool il just throw a fuse in. I get a fuse and go to put it in and notice there isnt even any metal terminals in the fuse box. Whats the deal? Is this the rite terminal? Any help is appreciated, thanks
 

Premium Member
Joined
26,484 Posts
Are you using the correct brake controller plug-in harness for under the dash?
For testing, the heavy blue wire is an output, the light blue activates. There are two fuses involved; under the hood, "STUD #2" is your main power, and on the side of the dash, "VEH CHMSL" triggers the activation.
 

Registered
Joined
35 Posts
Just throwing this out....I have older controllers that show they are working anytime you step on the brake pedal. When I got my 05 and put the brake controller in it (PO took it out when he traded it in), I hit the brake and the controller did not light up. After scratching my head and double checking wires for hours, I hooked it up to my trailer, and it worked fine. Apparently the newer (05 and up) controllers need to have the trailer plugged in to work.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top