Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 8 of 8 Posts

Registered
Joined
21 Posts
Discussion Starter · #1 ·
Bought this 02 and it had a brake controller and strobe kit well the brake controller didn't work when hooked up too a trailer. Well the controllers power is hooked up to a switch (shouldn't matter) but everytime I hit the brakes even un hooked it lights up then fades afterwards u would have to reset it (via power switch) then repeat. So I striped the strobe kit (wiring was a rats nest) and confirmed a good 12v power and good ground no change. But it obviously has a good brake switch connection because it lights up upon the brake.... So need opinions junk controller looks pretty old. Any help would be great thanks
 

Premium Member
Joined
26,482 Posts
Power feed has a 'switch'???
 

Registered
Joined
21 Posts
Discussion Starter · #3 ·
Yeah after looking at my dads 02 I realized that there is a harness that plugs in to the relay box user my dash. But they spliced the power wire into a switch why idk. But I got rid of that and hooked up the way it was just straight so I guess ill give it a shot I wouldn't think the switch would be to blame but could be?
 

Premium Member
Joined
26,482 Posts
Yes, use the harness. Make sure it's the correct one, the '02 is different than later models (1-wire swapped).

With the harness in use, constant power feeds from the #2 Stud in the Underhood Fuse Block.
Hit the manual switch/lever and check for brake activation.
Auto apply signal comes from the 3rd brake light, so check your 'VEH CHMSL' fuse in the Instrument Panel Fuse Block, left side of dash.
 

Registered
Joined
1,779 Posts
Also check whatever connector you have on the back of the truck for corrosion or bad wiring

What brand of brand of brake control is it?
 

Registered
Joined
21 Posts
Discussion Starter · #6 · (Edited)
Ok so if I hit the manual lever on the controller my 3rd brake light should light up to confirm its working properly? And its a brakemate mt
Cause as of now when I hit the brake pedal it lights up then fades and when the manual lever is slide on it lights up and fades then once released it lights up and fades again. No 3rd brake light tho with the manual lever got it on the pedel tho
 

Premium Member
Joined
26,482 Posts
Do you have a trailer hooked up?
 

Registered
Joined
21 Posts
Discussion Starter · #8 ·
At this current time no, but as said with the first comment when it still had the switch the trailer brakes did not engage even with the manual control and the trailer worked good on another truck. But after removing the switch idk if anything's changed will test on another trailer asap
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top