Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

421 - 432 of 432 Posts

·
Registered
Joined
·
6,734 Posts
Get rid of the lift and big tires or I'll still outrun you lol. In town I'm. At 18-20. I usually get from 5-600 to a tank in town. 650-700 highway. Tuning didn't change it, fuel additive didn't do anything, the 2 combined did squat. Might try changing my thermostats this year if I have left over pennies.
 

·
Registered
Joined
·
5,873 Posts
I got 19 pulling my 7400 lb trailer to Alberta 2 falls ago. Around town still sucks back 16-17. On the open highway, if I can stay at 100 or better, the economy starts to happen. Even on the Sea to Sky twisty, humpback camel highway. The corners aren't bad, you really don't have to slow for them even though there are warnings to slow down, but I drive that highway every day. It's brutal following someone that doesn't know the road.

Kyle, did you get an exhaust done yet? My cat was holding me back economy and performance. Patch truck...must have idled a lot. Lot of hours.
 

·
Registered
Joined
·
2 Posts
Just joined today although I have had the truck for three years. Lots of posts to catch up on!
 

·
Registered
Joined
·
2 Posts
Oh yeah.....from Abbotsford.
 

·
Registered
Joined
·
5,873 Posts
Welcome Dave.
 

·
Super Moderator
Joined
·
1,165 Posts
I'm shocked there aren't more of you guys. Anytime I'm in the Okanagan area, it's like every fifth vehicle I see is a clean Duramax. They're everywhere over there.
 

·
Registered
Joined
·
220 Posts
From Kelowna BCyou can always tell who takes care of their trucks , there is alot of Chev - Gmc around here, some nice ones ,
 

·
Registered
Joined
·
5 Posts
Yes, some even from sleepy Vancouver Island ! We have a 2005 Silverado 3500 dually, stock all the way, even the tires !
I am getting the error code for the idle-speed misfire, which I understand is normally caused by the harness for # 2 and # 7 injector being too short. I wondered if anyone has tried splicing in a slightly longer connector harness on both lines ? I am reluctant to spend $ 250 for the factory "repair" kit.
 
421 - 432 of 432 Posts
Top