Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 23 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Did a little road trip following an oil change yesterday.
6 qts delo 400 and 2 qts Lucas oil stabilizer (very thick stuff) plus a new Wix filter

As I neared my destination i noticed oil pressure way way down. On the gas (diesel) pressure would come up slightly but at an idle it was zero (in the red)...WTF?
No check engine light or any warning. Still running fine no knock or any noises.
Arrived, stopped, shut it off, let it rest, checked oil (full), fire it up and pressure is perfect (around 50-60).
Headed home today, pressure is again perfect over 60 while driving and down below 30 at an idle but as i get home (120 mile trip) it's hovering down near the red again at an idle (not zero but low).

Unload bikes for 30 minutes and fire it up and pressure is spot on 60+...WTF?

Any chance it's the 2 qts of lucas oil stabilizer I ran in there?
I have run Lucas full synthetic additive in the past but this is the first time I've run the thick ass oil stabilizer.

Is there a chance my OP gauge is acting up and sending a faulty reading?

The reason I ask about the gauge is that my speedo was all F'ed up on the way home too, like reading only half the speed i was actually driving

I will start by draining and replacing the the oil with 8 qts of delo 400 and another filter.


Also, it's an 05 2500 hd cc duramax, low miles

Thanks
 

·
Registered
Joined
·
577 Posts
im going to guess if you had speedo issues it was something up with the cluster, ive been running 8qts oil 2 lucas since ive owned my truck new and have never had an issue
 

·
Premium Member
Joined
·
26,484 Posts
Why 2qts low?

How does she perform with a full 10 qts?
 

·
Registered
Joined
·
577 Posts
How does she perform with a full 10 qts?
kinda my thought why 2 low? you are out of lucas specs (20%) and ive never had an issue with it, always starts good/good pressure at idle and hwy from what i thought,

what are good hwy runnin pressures and idle hot/cold?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
How does she perform with a full 10 qts?
LOL

No kidding? are you serious?
The oil level is always right in the middle of the dipstick whenever i check it
Damn! i hope I'm not that lame.
Unless i got my count wrong but i swear the level was correct before I left and whenever I check the oil between changes
 

·
Premium Member
Joined
·
3,633 Posts
mine when warm hoovers just above the red, ive seen several trucks do this so i assumed it was normal since the engine runs fine and i have no issues
 

·
Premium Member
Joined
·
26,484 Posts
LOL

No kidding? are you serious?
Yes.
2.5 gals.
You're not buying it by the gallon? Rotella does sell a single 10qt jug.
Surely you just miss counted?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
Is there a sensor or sender or connection that might be loose, something external that I can check for a loose wire/bad connection?
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
I have never run full 100% synthetic. Always a combination of Delo 400 and 2 qts of Lucas synthetic additive/treatment.

Only difference this time was the "oil stabilizer' from Lucas instead of the synthetic.
I was thinking the same thing that the thick ass stabilizer would only increase OP but it was not my intention, I was not adding it for that reason.

Does anyone know of a factory defect/issue involving the instrument cluster?. I have heard of them going bad, needing replacement.

can someone show me a photo of the oil sending unit where it's located on the block and what it looks like (what color wire are connected to it)?
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts
I might be wrong or reading it wrong.. And I dont think this will cause your low oil pressure but.. I dont think you can mix synthetic additive with regular oil and the other way around.

But ya these truck do get unusually low oil pressure. I would think its more the sensor. You could also take it to a shop and have them scan the computer to see what the computer is reading. That will rule out the sensor or the cluster.

Also, what is Clear creek? lol



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
1,416 Posts
check your batteries and ALL the grounds !! might be just a power supply or ground issue causing the cluster to act crazy ..i have seen it more then once on GM trucks mostly gassers though but worth a shot . Its weird that it happens once its nice and warmed up .but heat does make weird stuff happen . could be a weak battery that shits the bed once it warms up a little .
 

·
Registered
Joined
·
1,422 Posts
I might be wrong or reading it wrong.. And I dont think this will cause your low oil pressure but.. I dont think you can mix synthetic additive with regular oil and the other way around.

But ya these truck do get unusually low oil pressure. I would think its more the sensor. You could also take it to a shop and have them scan the computer to see what the computer is reading. That will rule out the sensor or the cluster.

Also, what is Clear creek? lol
I agree....What possible reason could anyone have for mixing synthetic and conventional?:cookoo[1]:
 

·
Registered
Joined
·
1,416 Posts
Then why do they sell syn blend ?
 

·
Registered
Joined
·
1,422 Posts
^^Good question.....
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #17 ·
I might be wrong or reading it wrong.. And I dont think this will cause your low oil pressure but.. I dont think you can mix synthetic additive with regular oil and the other way around.

But ya these truck do get unusually low oil pressure. I would think its more the sensor. You could also take it to a shop and have them scan the computer to see what the computer is reading. That will rule out the sensor or the cluster.

Also, what is Clear creek? lol
I'm pretty certain combining the two types is not an issue or there would be a HUGE warning on the label stating that.
i have run Slick 50 in many of my vehiles including this one although it is a teflon based oil.

On 2 stroke motors there is definitely compatability issues like never run a castor based premix with a synthetic or a blend or you will seize the motor.

CLEAR CREEK is the premier off road area used for the lat 70 years here in California. It is 70,000 acres of Dirtbike, 4X4, jeep, crawler heaven. Ranked in the top 10 areas in the NATION. it was closed to all use by our federal government. The BLM along with the EPA put together a bogus report 5 years ago telling us it is deadly to ride in there because of the naturally occurring asbestos in the serpentine soil. 100's of studies say otherwise regarding this particular chrysotile asbestos (there are 7 types of asbestos, this one is harmless and we have the studies and history to prove it) Thjey odered a "temporary" closure 5 years ago based on junk science. The BLM (buerau of land management) has lied, cheated, mislead, misrepresented, falsified data, broken their own policies, created new policies in an effort to keep it closed. it is shocking how corrupt the BLM is combined with the EPA and the anti access environmentalists (Sierra Club, CBD, CNPS) We are at the 5 year mark now waiting for their final draft/decision...5 years....5 years...5 fucking years, all based on junk science pushed by the greenies....don't get me started. It won't stop here, they will not stop trying to keep us out of the forests until they shut it all down.

Sory bout that, I get al little emotional :woopass
 

·
Registered
Joined
·
619 Posts
^ seems like a stupid reason to shut it down. Even if it is deadly to go there, why the fuck would they care? It's your body, it's your life. Smoking is a pretty bad habit, but is it illegal?
 

·
Registered
Joined
·
16,262 Posts
So wait, did you add the needed 2 qts of oil to see if the oil pressure gauge moves?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #20 ·
So wait, did you add the needed 2 qts of oil to see if the oil pressure gauge moves?
My oil level is correct. I may have misjudged the amount but....it is at the top of the mark on the dipstick. I did not need to add more oil.
 
1 - 20 of 23 Posts
Top