Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
ECM just died?
Hey guys. I flashed my brothers truck about two months ago with a tune from Motor Ops. Truck has been running good until Friday night. He was driving pulling a trailer and the truck just died on him. He was able to coast to the side of the road. We checked all the ecm fuses and they are all good.. The dash is currently saying "Service trailer brakes, service stabilitrak, parking sensors blocked". I can no longer communicate with the EMC. When i use EFI live I can see the A50 TCM but the ecm box comes up blank like it isn't there. Seems odd that the truck just shut off while driving and now won't restart. Tried jumping it incase it was the batteries with no luck. The truck wont even try to crank which i believe is do to the ecm being dead. So we purchased a used ECM from SoCal hoping that was the issue. Installed it and can't flash a tune. EFI live doesn't even show the ECM is there. However the TCM still shows up. Kind of at a loss with it. We will start tracing wiring but was hoping for some help on the issue. Is it possible to TCM took a dump and is making the ECM not connect even though I can still communicate with the TCM. Thanks for any help.
 

·
Registered
Joined
·
281 Posts
Check the wiring harness, mine rubbed through and took out the ECM. Mine rubbed like 6 wires through and had wires showing on a few more right behind the A/C compressor bracket.
 

·
Registered
Joined
·
2,471 Posts
When you first turn your key to on, there are many lights on your dash that will light up momentarily, one of them being the CEL (check engine light), and that should go out after the truck starts. If you CEL lignt isn't on at key-on, it means that your truck has lost communication with the ECM. If you attach a code reader to your DLC (data link connector), it won't power up or read any computers. This may be because the cigarette lighter fuse has blown, or other shorts to ground in the circuit. If you can't communicate with the ECM, you can't load tunes.
 
1 - 5 of 5 Posts
Top