Chevy and GMC Duramax Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I warmed my truck up this morning for about 5 min, Drove about 100 feet then my truck had no power ( it would crawl at 5-10 mph) check engine light came on and I heard loud knocking. I have 9500 miles on my 05 LLY. changed the fuel filter at 9000..
Anyone have this problem or know what is going on.

I have a AFE intake, BORLA exhaust, and Edge chip....
 

·
Administrator
Joined
·
8,815 Posts
try disconnecting the edge chip and see what happens. Did you run your tank low on fuel recently? I think there is a TSB for #3 and #7 injector harness plugs too. Do you have access to a code reader? It would be good to know what codes you have too. Wow, only 9500 miles on an 05....does it sit for long periods without driving? Just wanted to know if your fuel filter change was only 500 miles or 5000 miles ago.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
I would try unpluging the edge box. HOw cold was it when it happend, i've heard in some cases that when the edge box is extreemly cold it will throw fits! SOme guys even go as far as mounting them to there upper rad hoses!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yea I dont really drive it that much, maybe once a week. I changed the filter 500 miles ago. I have ran the fuel pretty low the last two refills. I unpluged the edge and it still had the check engine light on and still was in a limp mode. I am at work now so i cant mess with it but on sat I will see whats up with it. And It was pretty cold arround 50 outside that morning. So does this seem like more of a ECU problem than a fuel prob..
THANKS FOR YOU HELP....
 

·
Administrator
Joined
·
8,815 Posts
If you ran the tank low, I would try and change a fuel filter. It only takes a little junk to clog a filter. Without knowing what the code is, it is hard to point you in a direction though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Ok so I just got home and the truck is showing a P0206 and P2146, Both these have to do with injectors...
 

·
Registered
Joined
·
96 Posts
there's a newer bulletin your dealer should look at. #06-06-04-026. might be injectors but it could be chaffed wires around the fuel injection control module. it's on the passenger side of the engine towards the front. since it's setting both codes i'd say this bulletin will fix it but it'll need a good diagnosis first.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
0206 is a ficm(fuel inj. controle module) inj driver 6 fault. And 2146 is a circit fault in 1,4,6, or 7 inj. i would look at the inj harness on the pass side of the engin there was a problem with quite a few of them rubbing through and shotrting out the wires, i bet this is your problem!

Good luck,
Caleb
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Thanks Guys for all your help. This place is awesome. I took my truck into the dealership under warranty so I will let them get to the bottom of it. Thanks again....
 
1 - 9 of 9 Posts
Top