Chevy and GMC Duramax Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
795 Posts
Discussion Starter #1
Picked up a 03 friday, ran awesome got great fuel mileage on the way home. Drove it around that evening quite a bit, shut off and restarted fine. I thought my batteries sounded like they were getting weak, then saturday morning i start it up throw it in reverse and im about backed out when it dies. No funny noises just dies, Now everytime i try starting it back up i just hear the solenoid click and nothing else. I went ahead and put 2 new batteries in it and checked all connection and still just a click. Only other thing i found out of ordinary was this wire under the starter relay.
 

·
Registered
Joined
·
1,309 Posts
Take the wire out plug the relay back I'n.. See what happens
 

·
Registered
Joined
·
795 Posts
Discussion Starter #4

·
Registered
Joined
·
795 Posts
Discussion Starter #5
Alright when i pull that wire out and put the relay back in absolutely nothing happens. Turn key no click no nothing. The relay felt a little loose without the wire also?
 

·
Registered
Joined
·
795 Posts
Discussion Starter #7
my geuss is the relay died and a po "fixed" it
Yes thats prob what happened. So should i just buy a new relay? I figured it the relay was bad though i wouldnt hear the solenoid click?
 

·
Premium Member
Joined
·
17,806 Posts
Swap one of the other relays-- they are the same type.
 

·
Registered
Joined
·
1,309 Posts
Yea I'm guessing bad relay... That wire is not stock... Hopefully with that wire I'n there it didn't cause more Damage
 

·
it stinks and whistles :)
Joined
·
5,349 Posts
you could try a new relay and hope for the best, but remember a relay is just a switch so with the relay out of the circuit power was never shut off to whatever it controls.
 

·
Registered
Joined
·
795 Posts
Discussion Starter #11
Tried the other relay and exact same thing, nothing at all without the wire, click with the wire. Could that wire have fucked up the solenoid or starter? The part that doesnt make sense to me is how when this happened it started fine then died and now just the click.
 

·
Premium Member
Joined
·
17,806 Posts
I would check the batteries first-- be sure to disconnect one as they are wires together to make one big battery. Also cleaqn the cables.

If you have a volt meter, you can check battery voltage when you try to start it-- that will help diagnose to problem.

If you put the truck in PARK, and SET THE BRAKE, you can also jump the two terminals at the solenoid-- if it starts them-- most likely the problem is a switch/wire.

There are many electrical items in the starter circuit--
the NSBU switch-[attached to the side of the trans] ignition switch, the start relay, and the starter solenoid. They all have to work, or no start.
 

·
Registered
Joined
·
795 Posts
Discussion Starter #13
I would check the batteries first-- be sure to disconnect one as they are wires together to make one big battery. Also cleaqn the cables.

If you have a volt meter, you can check battery voltage when you try to start it-- that will help diagnose to problem.

If you put the truck in PARK, and SET THE BRAKE, you can also jump the two terminals at the solenoid-- if it starts them-- most likely the problem is a switch/wire.

There are many electrical items in the starter circuit--
the NSBU switch-[attached to the side of the trans] ignition switch, the start relay, and the starter solenoid. They all have to work, or no start.
First off I really apreciate all the help man im def not a pro with these motors yet. The batteries are both brand new but I will check all the wiring from them to the solenoid, starter, etc. That was my first thought was maybe something just shook loose. Another thing my shifter is really stiff i didnt know if something could be messed up there not telling the truck its in park and ok to start?

Worst part is trucks about 5 miles from my computer so i have to keep running to it to check lol.
 

·
Premium Member
Joined
·
17,806 Posts
You said the shift lever is hard to move-- that is usually caused by the shifter cable gettin rusted/corroded. Need to replace that.

Does it display the shift pattern on the dash-? If not the NSBU switch can affect that-- and if not going into park, it will not close the starter relay.
 

·
Registered
Joined
·
795 Posts
Discussion Starter #16
Do you know the starter works?
no i am not sure. And on the dash it does say its in park so im guessing that parts ok for now. at key on while the trucks still off should the service engine light be on? I have a buddy that has a scanner he could hook up and see if that tells him anything.
 

·
Registered
Joined
·
795 Posts
Discussion Starter #17
Found a loose conection on the starter that was causing the problem! Once i fixed that though just crank and crank and no start....turns out the little valve thing on the bottom of the fuel filter housing is leaking BAD, and i guess sucking air there. New fuel filter housing and starter connection and hopefully im good to go. Thanks for the help guys.
 

·
Registered
Joined
·
795 Posts
Discussion Starter #18
Today New fuel filter and water sensor (that little damn piece of plastic was 45 bucks). Fired right up and has run great all day. Will have to wait till tomorrow to make sure it keeps prime over night. So far so good!
 
1 - 18 of 18 Posts
Top