Chevy and GMC Duramax Diesel Forum banner

1 - 9 of 9 Posts

·
Reign in Blood
Joined
·
4,555 Posts
Discussion Starter #1
Every time I turn my truck off the clock resets to 12:00 anybody run into this ever? Anybody fix it...I may just see if I can find a GM Bose NAV for a reasonable price if its fubar.

Thanks for the help :drink
 

·
Registered
Joined
·
1,299 Posts
yes mine was just doing this. it really ticked me off. go tighten the terminals on your batt. one of mine worked loose just a little bit everything worked except my clock reset itself all the time. all it takes is just a lil loose so go snug em up and see what happens
 

·
Reign in Blood
Joined
·
4,555 Posts
Discussion Starter #3
yes mine was just doing this. it really ticked me off. go tighten the terminals on your batt. one of mine worked loose just a little bit everything worked except my clock reset itself all the time. all it takes is just a lil loose so go snug em up and see what happens
nice ill hit em up
 

·
Registered
Joined
·
1,299 Posts
no prob it ticked me off cause mine did it for like a month and then thats all mine was
 

·
Registered
Joined
·
235 Posts
This thread might help me out too. mine has done the same thing twice in the last month. I was so confused
 

·
Registered
Joined
·
1,299 Posts
yeah someone should make it a sticky to just check your batt terminals if you notice your clock acting funny. ive read alot of older post saying to do the same thing and wala it fixes the problem most of the time.
 

·
Registered
Joined
·
138 Posts
I had the same problem. It was actually a bad battery. One was fine but the PS battery was shot. Replaced it and haven't had any problems since.
 

·
Reign in Blood
Joined
·
4,555 Posts
Discussion Starter #8
ok here is the deal, when i turn the key to on, the clock has the right time, when i start the truck it resets. i checked the terminals, the drivers side will not tighten completely and the passenger side is tight.
 

·
Registered
Joined
·
1,299 Posts
well if the drivers side wont tighten completly their is your problem. maybe a terminal is rotted or something id be getting that battery tested bet ya its your problem that or if you have a new battery put it in their and try it
 
1 - 9 of 9 Posts
Top