Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2001 Duramax that has is on it's 3rd set of injectors with 120K Mi

Last summer it blew a head gasket. Took it to the dealer and it took 3.5 weeks to get it repaired

Got the truck back and no accelerator power. They replaced the Torque Converter

That did not fix the problem. Turned out they had to replace the injectors again. That seemd to work

Now under load while towing my 31ft trailer when accelerating reaching 55-60MPH when gear shifts I lose power. Zero pedal. I pull over and shut it down. Wait a minute or two. Start it and runs fine. Once I hit between 55-60MPH and shifts it happens again.

I have had this same problem in the past and replaced the injectors then and it was fixed

Not sure if all of the injectors were replaced

Is there a test to see if the injectors are working properly?

Also the code that is pulled is P0234 Turbocharger Wastegate Solenoid A Malfunction

Any ideas. My GM/Chev dealer lost their Diesel Mechanic. Not they he was very good anyway
 

·
Administrator
Joined
·
8,815 Posts
when is the last time you changed your fuel filter? I am assuming your truck is all stock right? that overboost code could cause your truck to go into limp mode like you are describing. Also, when is the last time you serviced your tranny? It almost sounds like a tranny limp. Do you get a check engine light when it makes that shift? Can you at least hold 2000 rpms? Welcome to the forum...to bad it wasn't under better terms.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
It was May 07 that the dealer replaced the torque converter in the tranny and that did not fix what was later found to be bad Fuel injectors. They replaced those in June 07.

Took it out for a trip and had this new problem. The service engine soon light comes on. If i don't run it for a few hours that light goes off on it's own

I don't think that it would be a bad filter. The dealer said that it is still under 15K on the new one.

Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Also when it goes into limp it loses all speed and will not excelerate. I can barely make it to the side of the road without getting hit.

I am leaving on another trip and will be towing agian. I will have to keep it under 55Mph and should do fine

Do you know any good Diesel Mechanics north of Seattle WA?
 

·
Administrator
Joined
·
8,815 Posts
Remember, it only takes one bad tank of fuel on the fuel filter to make it bad. How many miles do you have on it? If you have 5000 or more on it, I would start there. the fuel filter really needs to be changed every 10,000 miles. The ones that I have cut open after only about 7500-8500 miles was totally black. the way I look at it, it is cheap insurance on a very expensive engine.
 
1 - 6 of 6 Posts
Top