Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
Hey all, check engine light came on 4 days ago, pulled the code (and cleared it) yesterday and it was P0670. Today, it came back on. I have been reading and want to pick your brains. Who has had this problem and how did you make it go away? I could replace the module if I am 100% sure it will fix it but just wanna check with you all.

FYI, I have an installed remote start VIPER and do you think the 10 sec delay from activation to start would have anything to do with it? The system was installed by best buy. I don't know why they didn't hard wire directly to the glow plug indicator light. . . could I do that? ugh. . . I wish I had more know how.

Thanks for the input.

:gearjamin
 

·
Registered
Joined
·
399 Posts
i had this same code, i also have a remote start alarm. i replace the glow plug module and it went away, been fine since. its an easy swap.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #3
Thanks Murphdiesel!!! :drink
 

·
Registered
Joined
·
69 Posts
how much was it? does it have to be flashed or anything? where did you get yours? im having that same problem, but im not throwing a CEL. i scanned it a day or two ago, got P1093 and P0670, i know what both of them are, im just wondering does that mean the glow plugs aren't lighting up, i've noticed it takes a little longer to fire up, like one or two more rotations of the engine to start. would that cause this?
 

·
Registered
Joined
·
399 Posts
i think it was about $100, got it from gm parts dirrect. i never really had starting issues except when the batteries were going bad, but now that i think about it it does start up quicker after swapping it out. i hope that helps...
 

·
Registered
Joined
·
10 Posts
Was it fairly easy to install is it somethin most could do in they're driveway or is it kinda complicated

Sent from my C771 using AutoGuide.Com Free
 

·
Registered
Joined
·
175 Posts
Ya its a driveway repair. Module will be at the rear of the drivers side valve cover. A large power wire ans one or possibly two plug in connectors and a couple mounting bolts.
 

·
Registered
Joined
·
3,774 Posts

looks like the one in the link - got mine on amazon for $75 + free shipping :D

not hard takes about 20 mins
 
1 - 8 of 8 Posts
Top