Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2003 Duramax/5 spd allison....

Just recently had the NSBU switch go out. Installed new one to some specs I actually found here. It's why I became a member. Anyway, truck will not turn over at all now. Battery seems fine. Not a mechanic but can figure things out, but this has me confused. Any Thoughts???

Thanks
 

·
Premium Member
Joined
·
505 Posts
This is what I would do....one more time, check it. Did the defective NSBU prevent your truck from starting?
 

·
Registered
Joined
·
553 Posts
did it have the center tabe on it , it has been a long time sence i installed one. you probly have to adjust , does the shifter line up with the gear on the pringel is drive ,resverse, nuteral ext ? where it should be
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Checked all that stuff out in the above posts. Ran through the fuses as well. Heard ignition switch could also be bad for some reason. going to check multiple things i guess until I can get it to start. It's my work truck for hauling tile so I have to get it running. Thanks for your responses though.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Well.....I feel a bit stupid. The fix was easy. A loose wire on the pigtail of the bigger connection. Since it was glued on, I pulled one of the wires out and didn't even notice. A buddy suggested to double check the wiring. Good thing. Almost had it towed to a shop and paid out the wahoo for nothing. Truck runs fine now. :)
Thanks for everyone's input.
 
1 - 5 of 5 Posts
Top