Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Needing some insight on 2013 lml bone stock not deleted. Here's what i have going on:
When idling for a while (hooking up camper) or towing camper at 9,000lbs for roughly hour and a half in tow mode exhaust brake "coolant level low add coolant" comes on. Level seems right at about sensor level with some coolant in non pressurized side. Cools down over night, level is back to normal at cap (but tank level is readin below min on outside of bottle, but full at cap???). Hose at cap is not rock hard just standard feeling to me and can squeeze it somewhat. To make sure its topped off, I take off upper hose and level goes down maybe from air lock? So I top it and idle it to temp and level never goes down with cap off, so i go on my way.
Had a guy do some pressure tests and he's ruling out everything but internal leak. Says i have an internal leak but he wants me to get second opinion. Well i get home from his shop and now I have def quality poor light on that i cannot get off at all. Check engine light finally come on so i could get a code and its p20ee catalytic emissions below threshold so i clear it and def quality still on. Its derating down on speed soon and I've parked it. Talked to several mechanics and its either egr cooler, head gasket, or maybe just tank and sensor. Most are leaning toward egr. Maybe 3-4 times in past few years I've seen a puff of white smoke randomly since i don't drive it too often. 107k miles on truck with 6in lift. Anybody had this happen? Either way I'm deleting it soon cause this emissions crap has given me more problems that anything. Truck feels like it runs and shifts fine.
 
1 - 1 of 1 Posts
Top