Chevy and GMC Duramax Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
Got a weird one for everyone about two months ago found I was loosing coolant and every morning it would leave a stream of white smoke for about 30 sec then quit. It was also accompanied by a miss on startup after it was warm fine no smell. well I diagnosed it and found coolant in #3 cyl I replaced the head gaskets and installed head studs got it back together an ran like a champ after a week noticed a coolant smell again. Now its back to doing the same thing. Everything was tourqed to spec and am very meticulous about cleanliness and specs. Any ideas on where to head on this going to pull glow plugs again and find which cylinder. But other than that I'm stumpped.
Symptoms.
-coolant smell
-white smoke on start up
-only slight coolant loss and only when cold
-rough idle on start up
-no lack of power
- no intermix
-no over pressure of system
-coolant resivour turning black

Items replaced/ machined
-headgaskets
-studs
-waterpump
-thermostats
-heads machined at local shop and pressure tested checked all ok
 

·
Registered
Joined
·
7,376 Posts
Do you have EGR emissions?
 

·
Registered
Joined
·
7,376 Posts
You may have an injector cup that isn't sealed properly. Normally that would build pressure in the system, but if the cup is leaking (not a perfect seal) and not popped (loose in the head) this could cause the coolant to leak into the cylinder when sitting and exhaust fumes to enter the coolant system.

I don't believe the turbo coolant lines come in contact with exhaust even if there was a leak in the turbo. And the only other way for coolant and exhaust to mix is head gaskets if you don't have EGR.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #5
All injector cups where removed,and #3 cyl cup was replaced and cleaned the bores meticulously and applied loctite per gm s.i.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #7 (Edited)
About a quart every week only leaks if it has a heat cycle and when it gets cold is holding 15 psi of pressure and dropping 2 psi per hour. Trying out some system sealer through our shops BG rep. Supposed to not plug anything up.
On a side note no smoke this morning but still smelt coolant and after adding the sealant no smell this afternoon . have not really drove the truck a long distance yet drove it 30 miles today could it just need a good heat cycle to set a good seal?

I do have a question at what mileage should I retourqe the headstuds .
 

·
Registered
Joined
·
310 Posts
Discussion Starter #8
Update: added the BG sealer and put about 100 hard miles and reevaluated the issue. No smoke and no smell suspect putting a good heat cycle and having the sealer in took care of the issue and sealed everything up. I'll know in a week if it took care of it.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #9
Update: drove the truck about 300 miles this weekend and no coolant loss and no more coolant smell. The truck is running great and the cooling system seems to be working great. Builds pressure in cooling system without pushing coolant hose stays hard for a few hours where before it would be soft within 30-45 minutes. yesterday morning the top hose was even partially collapsed indicating a good system seal. My truck Is officially fixed.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #10
Update: Last weekend my wife and I went and picked up our new boat. truck ran perfect no overheating got 19 heading into wenatchee about a 200 mile drive and 16 headed back home with the boat. Took it preaty easy on the way back though no gauges quite yet didn't want to blow another head gasket.
 

Attachments

·
Registered
Joined
·
22 Posts
I know
Update: Last weekend my wife and I went and picked up our new boat. truck ran perfect no overheating got 19 heading into wenatchee about a 200 mile drive and 16 headed back home with the boat. Took it preaty easy on the way back though no gauges quite yet didn't want to blow another head gasket.
this is a old thread. I have same problem. Can you tell me what sealant you used fro BG?
 
1 - 11 of 11 Posts
Top