Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
2005 3500 the ect is surging when the truck gets up to temp. its not the stepper motors also does it on the edge cts. after about 20 minutes of driving the ntruck starts this. When the temp surges the desired and actual fuel rail pressures drop and the truck looses power. I have checked the wiring at the alternator and everything looks good and changed the coolant temp sensor. nothing has helped new feul filter and still nothing. should the plug for the temp sensor ohm out ground?
 

·
Ask one to be one
Joined
·
5,660 Posts
Thermostats are sticking. The reason you are loosing power and rail pressure is the edge increases power as the engine get to operating temp.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
the edge is just an insight and the efi live is the tuner it is doing this in all settings including stock
 

·
Ask one to be one
Joined
·
5,660 Posts
Depending on you tuning efi will add power the same way. Also the factory tables take into account coolant temp as well.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
so you would lean more to thermostats than wiring?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Thanks for the help ended up being the connection for the wiring harness near the turbo was not properly seated. One side was broken and when i hit a bump it acted up.
 
1 - 6 of 6 Posts
Top