Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter · #1 · (Edited)
I had an issue a while back, my clutch pedal worked loose a little and got down into some wiring... ended up cutting a couple of wires before i realized it was an issue.

I got everything fixed as far as the wiring was concerned (or so i thought?) but since this took place, there is no backlighting in the gauge cluster OR for the hvac controls. Therefore, no dash backlighting at all. For a while i thought maybe just a bulb burnt out in the cluster, because there was only 1 working in the gauge cluster BEFORE this clutch pedal incident. so figured the other blew when the dash lights went nuts with those wires getting cut and coming in contact.

The gauges and lights on the cluster work, just not the backlighting. can't see what's goin at night time.

If i can track down which wire provides power for the backlighting for both the gauge cluster and the other dash backlighting (hvac), then i may be able to get it fixed. but there are so many wires, and i reconnected the ones that were already cut... so not sure where to go. really need a wiring diagram to figure out which ones to test.

Is there a wiring diagram that includes/shows the dash/gauge cluster wiring?

:help :eek:
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #2 ·

·
Registered
Joined
·
241 Posts
Discussion Starter · #3 ·
Bump
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #4 ·
Any Electircal Gurus?

is this the wrong forum?
 

·
Registered
Joined
·
7 Posts
Sounds like were having the same issue. Did you ever find the solution?
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #6 ·
nope... not yet. I dread digging into it. plus i work 2 jobs, therefore hardly any time to even think about tearing it apart and tracking down the problem. I think i can fix this, just have to find the time.

you had wires cut/shorted out due to clutch pedal?
 

·
Registered
Joined
·
7 Posts
check your tbc fuses on the fuse block inside the drivers door. I decided last night I was going to tear into mine but I wanted to check all the fuses first and that's what mine was!
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #8 ·
Hmm... I went through all of them once already, replaced at least 3 or 4 that were blown, but still don't have any lights... maybe i missed one?

Do you happen to know exactly which fuse it was? or maybe how many amps the fuse was? that would be nice to just replace the fuse and that fix it... but i don't think i'll be as lucky. :/
 

·
Registered
Joined
·
7 Posts
I'm pretty sure the fuse was labeled TBC 1. I know it was 15amp. It was in the bottom right. hope that helps!!
 
1 - 9 of 9 Posts
Top