Chevy and GMC Duramax Diesel Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
809 Posts
Discussion Starter #1
I went to pass a SMV when i gave it more fuel it changed gears of course then it revved up and didnt get any faster,so i let off of it and finally made it around the car gave some more pedal still did it,i put it in nuetral back into drive then it was fine,so was it a limp?
 

·
Registered
Joined
·
209 Posts
I went to pass a SMV when i gave it more fuel it changed gears of course then it revved up and didnt get any faster,so i let off of it and finally made it around the car gave some more pedal still did it,i put it in nuetral back into drive then it was fine,so was it a limp?
any codes?
 

·
Registered
Joined
·
809 Posts
Discussion Starter #4
just checked with quad,no codes
 

·
Needs more go fast
Joined
·
12,518 Posts
either sounds like that or fuel filter
 

·
Registered
Joined
·
209 Posts
Doesn't sound like a Limp, normally when you limp, your tranny goes into neutral and wont change gears until you stop shut off and start again, at least thats my experience when my tranny Limped. Usually there is a code related to the tranny 0700 plus whatever code for the problem itself!
 

·
Registered
Joined
·
809 Posts
Discussion Starter #8
any other thoughts??
 

·
Registered
Joined
·
2,899 Posts
It's running out of fuel. What level is the quad set at?
 

·
Registered
Joined
·
809 Posts
Discussion Starter #10
was set at 135,i turned it back to 50 now!!
 

·
XBoxLive: RenegadeDuramax
Joined
·
1,776 Posts
My truck does this when my fuel filter is dirty. It's not slipping... it's starving.
 

·
Registered
Joined
·
809 Posts
Discussion Starter #13
My truck does this when my fuel filter is dirty. It's not slipping... it's starving.
I hope that is all mine is doing,cant afford a tranny!
 

·
XBoxLive: RenegadeDuramax
Joined
·
1,776 Posts
It's not your tranny. Change the filter and you'll be good to go. Let us know.
 

·
Registered
Joined
·
809 Posts
Discussion Starter #15
yeah,I read on another post that some put the shims in ,maybe that would help also? but i will def. replace filter
 

·
Registered
Joined
·
2,899 Posts
Since you had it running at 135, it was starving for fuel when you hammer on it. If you didn't hammer on it, its a dirty fuel filter. You should keep a spare filter in the truck in case the filter plugs up on you down the road, it will save you from a tow home.
 

·
Registered
Joined
·
469 Posts
Mine revs up like that too if I am in a high gear and give it some gas it revs up like its downshifting but it doesnt seem to go any faster, I doubt its fuel though because the motor sounds fine, it just revs. Now you got me thinking....
 

·
Registered
Joined
·
34 Posts
ill have to check that out too..today on my way to class the truck was "sliping" as I was just touchin the gas..sorta like ure going along on a snowmobile and just tapping the thumb for little burst of speed. well it didnt catch right away..but it shifts great when im just driving normal.
 

·
Registered
Joined
·
218 Posts
it sounds like a slippage or quite possibly limp mode. To me this does sound like limp mode or a dirty filter.. When i had my stock allison and a PPE it did it all the time when i raged it. Felt like the damn transmission fell right out underneath my truck, and as described it would just sit there and rev, not go over 40 mph. So as this gentleman did, i stuck it in neutral put it back in drive and was good to go. Try changing the filter, get on it and if it does it again you either need a lift pump or keep away from that 135 tune.
 
1 - 20 of 23 Posts
Top