Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
578 Posts
Discussion Starter · #1 · (Edited)
I think I may be have some injector problems. There is no smoke, but I may be getting diesel in my oil again.

Until last fill up the only additive I had been running was a GM Diesel additive every 1,000 miles (per the diesel mechanic's recommendation at the GMC Dealership here in town).

The other day I decied to try the TCW-3 2 stroke oil from Wal-Mart. I added 8oz to the 26 GAL tank. Everything sounded ok, until I pulled an empty 18' utility trailer.

Here is a video of me accelerating. I don't know if it's me being paranoid of if there is a slight knocking sound when under load.

Details about the video:
The throttle was at about 50% here with the empty trailer (no smoke).
Windows are up.
Everything is still stock.


I hardly get smoke even under full throttle, if any at all. I'll upload some other videos from the same trip.

Thanks for any suggestions.
 

·
Registered
Joined
·
84 Posts
possibly same thing

I have a similar video on my page if you wanna search LB7 knock?? Video, IMO it kinda sounds the same. I have been told anything from valves need to be adjusted to nothing wrong. Honestly, I believe my tranny is gonna take a shit and it's my torque converter. The only reason I say that is cause when going down the freeway with the cruise on, the sound disappears when everything is in balance. Once you throttle it, it starts knocking again. I have plans to have Alligator Performance put in one of there stage 5 trannys soon, and if that helps I'll keep you posted. Hope this helps.
 
1 - 3 of 3 Posts
Top