Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
2003 Chevy Duramax, automatic. It starts, runs about a second, then dies and will not start again till it desides to start again. This happens about twice per month. I took it to service they changed the crank shaft position sensor, this did not solve the problem. truck also has a Hornet alarm with remote start etc.. I don't know if that might have something to do with it? I have also repleced the fuel filter. It also has BANKS. Any and all help will be greatly appreciated!!
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
I had this happen to my lly once when it was brand new. all i did was switched a relay in the under hood fuse block, i switched the relay marked f-pump with the drl relay, some guys tell me that there is no way this is posiable but i have never had an issue since and my drl's did not work for a few days so that tell me that the relay was stuck, but just an idea to try. when mine wouldent startalso my fuel gauge showed empty even though it was 3/4 full???

Good luck,
Caleb
 

·
Registered
Joined
·
96 Posts
well if the security light is off then i'd really doubt that your remote start would be the culprit.i'd say that's ok then.

lly might be on to something. give that a try and let us know. gm has had some relay problems as of late.
 

·
Registered
Joined
·
2 Posts
duramax probs

Hey,my 03 duramax is doing the same thing.cranks,runs a couple secs,dies out.Will not crank at all afterwards.It's been to the dealer twice.He put a new fuel pump relay in and said it was fixed,but still doing the same thing.Any ideas?
 

·
Registered
Joined
·
2 Posts
Reluctor Gear?

Howdy, this is my first post. My dealer says the reluctor gear is loose on the crank causing a no start issue, has any one else had this problem? I will post this in acouple of places as I do not trust the dealer.......BD
 

·
Registered
Joined
·
6 Posts
I have had this happen to me 2. So, I opened the hood and pumped the fuel filter prime pump about 6-8 times and all was good. I changed the fuel filter and didn't get the bleed screw all of the way tight and it did it again cause over night the fuel would bleed down or something. So I tightened it and all is good now:)
 

·
Registered
Joined
·
13 Posts
not to sound like an idiot, but if your fuel gauge is not functional or reading empty, is it possible there is a fuel leak? while driving? while parked? perhaps it really is out of fuel. As I understand the the FP relay and the fuel gauge are seperate systems....that would be one heck of a coincidence. Not starting, not reading fuel? I know it's happened before and "no fuel" is likely not issue, but perhaps this time it is? I have seen a tank piss fuel. unlikly but it happens....

Just thought I would ask....

Mag
 

·
Registered
Joined
·
40 Posts
I have had this happen to me 2. So, I opened the hood and pumped the fuel filter prime pump about 6-8 times and all was good. I changed the fuel filter and didn't get the bleed screw all of the way tight and it did it again cause over night the fuel would bleed down or something. So I tightened it and all is good now:)
My friend with an 01 dmax had the exact same thing going on as you did bigal. Not sure if he has found the leak yet.
 

·
Registered
Joined
·
142 Posts
I have heard of this problem popping up when people change the fuel filters. Though I have not had the problem myself, it seems to come from the bleeder screw being cracked and not allowing the fuel system to pressurize properly (causing an air pocket the fuel can't get through). For some reason, there is not a visible fuel leak either. I have hear that the bleed screw is plastic, and usually in stock at your local dealer.
 

·
Registered
Joined
·
14 Posts
I,ve got an 02 D-Max that keeps tripping the S.E.S. light. The code is "Engine overboost". It then goes into limp mode and wont let me exceed 1900 RPM,s. It usually happens when I am exiting the highway ramp. I,m curious if the turbo wastegate is not working properly? There is a OBDII code for that malfunction but it never comes on. Very frustrating !!!
 

·
Diesel Addict
Joined
·
7,754 Posts
I,ve got an 02 D-Max that keeps tripping the S.E.S. light. The code is "Engine overboost". It then goes into limp mode and wont let me exceed 1900 RPM,s. It usually happens when I am exiting the highway ramp. I,m curious if the turbo wastegate is not working properly? There is a OBDII code for that malfunction but it never comes on. Very frustrating !!!
did you add any sort of after market performance things to the truck or is it stock?
 

·
Registered
Joined
·
13 Posts
I,ve got an 02 D-Max that keeps tripping the S.E.S. light. The code is "Engine overboost". It then goes into limp mode and wont let me exceed 1900 RPM,s. It usually happens when I am exiting the highway ramp. I,m curious if the turbo wastegate is not working properly? There is a OBDII code for that malfunction but it never comes on. Very frustrating !!!
Interesting....I wonder if the recirc BOV is not letting off the pressure on decel.....if this happens when you come off the throttle from the highway perhaps it is causing an overboost condition......just a thought, I don't know what kind of code *if any* a BOV would throw....likely none....perhaps it's intermitant?

I just fly planes, I don't fix diesels......:rockin

Like everyone else will tell you here......pull off the Bully Dog and see how it works for a couple days....might be a start...
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top