Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
have a 04 lb7. I had a bullydog on it but would cause me nothing but problems but only when I had the actual unit plugged in and screen on. I took it off my truck and installed a edge evolution cya tuner. On the way to the lake the fuel gauge all of a sudden went to empty and never has worked since and also if I put the fuel gauge pid on the edge it shows 100 percent even though it’s really not full. I can clear the code but it will come right back to e on my cluster. Also the security light came on and had to clear that code and a couple of times my truck has just died at idle like you turned the key off but will start. Is this a ecm issue? Should I buy a diff ecm and have it flashed to my vin??
Also yesterday my security light came on and my ac quit working and went to heat at the same time. It’s really being a pain. I just put new injectors in so I’m already out a ton of money so I really don’t wanna get a ecm unless I’m almost certain it’s the problem. I was wandering if a ignition cylinder could do something like that
 

·
Registered
Joined
·
1,851 Posts
What happens if nothing is plugged into the DLC connector? Still have same problems? Have an aftermarket radio? What other non-stock electrical things do you have? I wouldn't jump to bad ECM unless you can prove that the ECM is really the problem.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
I haven’t tried it with the edge unplugged from there but when the bullydog was on there it would be fine unplugged and nothing would happen. I bought this truck a little over a year ago so I’m unsure on the history. Yeah it has a aftermarket radio but not sure what that would have anything to do with it. My truck also died and my edge froze up the other day and it said it had lost communication but was able to get it started back up
 

·
Registered
Joined
·
1,851 Posts
Almost EVERY ELECTRONIC DEVICE in your truck can cause problems in running correctly and even starting the truck. Most every device feeds to the ECM, BCM, EBCM, etc and all those talk to each other. If the communication line is corrupted, you can have problems ranging from minor to won't start or run. Lost communication by the EDGE is telling you that is EXACTLY what happened.

Remove anything from DLC and remove fuse that runs the radio and see if problems continue. That will tell you something.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Oops I meant cts tuner. Dang autocorrect. It just died again sitting at idle at a stoplight but started right back up. I’m going to the lake after work so I’ll see if any issues happen when my tuner is unplugged from the port
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Drove to the lake and back with the cts tuner not plugged into the obd port and just like the bullydog everything is fine when it’s unplugged
 
1 - 6 of 6 Posts
Top