Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Looked around and this seems as good a place as any for this question. If I'm wrong (again) please move to the proper place.

Just received my Edge Insight CS2 monitor. Not a tuner, just for monitoring engine performance.

Per the users manual, I went to the website and registered the unit. Think I did. Got an answer something like, "Thanks for registering. We'll be in touch soon." What the hell does that mean? It's been like 3 hours and nothing. These things are usually automated and you get an (almost) instant response.

Then I downloaded and installed the Fusion software. It immediately went online and downloaded/installed an update - as big if not bigger than the original download. I open the Fusion program, per instructions on page 10 of the manual, and click on "Create a New User" - - - and get a message that says,
"Please follow the instructions provided by technical support.
The system cannot find the file specified.
Edge Products Tech Support: (an 888 number)."

I call the number provided and get a message saying the call cannot be completed at this time, please try again later. Tried this 3-4 times.

Is there a secret to dealing with Edge Products and using their software? What is it?
 

·
Premium Member
Joined
·
4,633 Posts
'dunno; Ive called them 2-3 times and Customer Service was always there to help asap. Perhaps you called when it was not their business hours?
 

·
Registered
Joined
·
7,275 Posts
The fusion downloads can take sometime doing, I’ve had several taking 30+ minutes.
It’s the beginning of the holidays they might be shut down until after Thanksgiving probably until next Monday if you can’t get thru.
I don’t think the “we’ll be in touch soon“ meant they’ll be giving you a call, 'dunno; what they meant.
Maybe go back thru the procedures or just hook it up to your truck and see what happens.
Remember when it starts up it’ll show for FORD, DODGE or GM/Chevy vehicles, select what you have then confirm what you selected.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Finally got thru to Edge this morning after several tries. More problems or missed communications there but the end result is that they got me fixed up and everything is working. :smile2:

Once I got Fusion working/connected there was a pretty large update to the device. :grin2:

I did do what D_R_C suggested and hooked the monitor up to the truck and set it up while I was waiting for tech support to respond. That went smoothly but - - - maybe this will change now that it has been updated - - - there were some big differences in what the dash gauges were showing and what the CS2 was reporting. I will probably be back asking about that with more specifics (and maybe a photo) after I use it and get more used to it.

monkeyman - - - I don't do facebook.

Thanks to all that responded.
 

·
Registered
Joined
·
7,275 Posts
Just remember once you get the pids/gauges you want in the areas you want.
If you unplug the Insight when you plug it back in make sure you select your vehicle make when it turns on and confirm your selection.
If you don’t it goes into default settings loosing your selections, then you’ll have to start all over with your selections.
It’s a learning experience on what that little device can do “good luck”.
 

·
Registered
Joined
·
958 Posts
If it’s the engine coolant temp, that will be different. Actual cts temp will be in the 180–190 range whil gauge in truck read 210.
 
1 - 7 of 7 Posts
Top