Chevy and GMC Duramax Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
well i got a egr blocker plate for an 05 lly,,, nd welll i took off the egr put it on the blocker plate and put it back together,,,,, but the plate didnt line up right where i put it on but didnt think much about it,, started the truck up nd she wouldnt run for shit,,, so i took it all off,, btw all of this was done around 10pm to 12 am with cell phone light cuz i was so excited to finally get it blocked,, nd now that it didnt work with all the frustratio0n i went through , im pissed!,,,,, Noomore
can someone post pics on how to do it or give better instructions then what i already had :help
 

·
Vendor
Joined
·
966 Posts
I think there is a good thread on here on how to do it.Can't remember the name of the thread but you can search for it. If you had it apart and done I don't know why your truck wouldn't start. I did mine but not sure if there is a difference in motors.hopefully someone with more knowledge will chime in. good luck.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
what i meant is that it would start,, just not runn right at alll
 

·
Banned
Joined
·
2,605 Posts
I had to grind the sides of mine for it to fit in all the way..... Sounds like you had the same problem I did
 

·
Registered
Joined
·
615 Posts
nd if it didnt line up nd why did you try to start it?? nd stop makin' us texas guys look dumb with the spelling.....it's not that hard to type "and" man.:confused:

But as for your EGR, the flange is up against the firewall on the passenger side. Make sure you have the plate in completely and the gasket is on the firewall side of the blocker plate! Where in Tejas you from? sorry about the whole grammar thing abbreviations just annoy me! :neener
 

·
Banned
Joined
·
2,605 Posts
Also, make sure the gasket is on the firewall side of the blocker plate.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #8
well im just frustrated with this whole thing so i could care less about the spelling and it doesn't help that im lazy,,, and i made the the plate fit, and when i started it i had this whistle and the truck just didnt run right, i mean it is cold but still it ran different from when i had the plate off,,,
does anyone know of a site that has pics on how to do this?
 

·
Banned
Joined
·
2,605 Posts
I am sure you're doing it right.. Only one place it can go in dude. Did you feel around the plate to see if you could feel it leaking?

Once you get the bolts loose its SUPER easy.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #10
I am sure you're doing it right.. Only one place it can go in dude. Did you feel around the plate to see if you could feel it leaking?

Once you get the bolts loose its SUPER easy.
yea, it was for sure leaking around there,, but ill give it another go tomorrow, i think i just had the gasket on the wrong side,,
 

·
Registered
Joined
·
615 Posts
Yuup sounds like it was on the wrong side.
Sorry bout bein an ass I had drank a few beers at a concert last night! :drink
haha you never said whereabouts in the state ya are?
 

·
2500HD Club Member
Joined
·
1,500 Posts
and it will take a day or two to seal completely back up so you may hear a little leak but it will seal back up and be as good as new or better!
 

·
Registered
Joined
·
46 Posts
Discussion Starter #13
haha got it figured out, lets just say working in the daylight helps
 

·
Registered
Joined
·
46 Posts
Discussion Starter #14
Yuup sounds like it was on the wrong side.
Sorry bout bein an ass I had drank a few beers at a concert last night! :drink
haha you never said whereabouts in the state ya are?
its cool,, lol beer can do that to you ,,. Im from canton tx,,
 
1 - 14 of 14 Posts
Top