Chevy and GMC Duramax Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Just installed the all season 3 inch bridge, I made my own egr riser plate from 1/8th inch flat steel, I ran the truck and got a p0299 turbo underboost code. That is the only code I get, I noticed that the gasket for my riser cap hangs out a bit, any thoughts? Is there a way to check the blocker plate for leaks?

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
53 Posts
Discussion Starter #2
Anybody had this code?? P0299??

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
I was looking around my up pipe and can't see any soot and there's no whistle, guess I hafta make a leak tester for my bridge and check the o-rings

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
271 Posts
does your tune have the egr turned off and setup right? I had same code on my truck when i just turned EGR off in tune w/o changing anything else
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
Not sure I'm running a duramax tuner tune, got it when I had just the blocker plate in, the scan tool I used also had an egr code but it said performance closed

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
does your tune have the egr turned off and setup right? I had same code on my truck when i just turned EGR off in tune w/o changing anything else
What do you mean by changing anything else? What should I look for?

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
5,778 Posts
Just installed the all season 3 inch bridge, I made my own egr riser plate from 1/8th inch flat steel, I ran the truck and got a p0299 turbo underboost code. That is the only code I get, I noticed that the gasket for my riser cap hangs out a bit, any thoughts? Is there a way to check the blocker plate for leaks?

I agree with Dustin, your EGR cap is probabaly leaking. Remove it, clean all mating surfaces with brake cleaner and reseal with high temp silicone (orange stuff). I hope you made a cap that attaches to the block where the cooler did too (see pic) or you may have a hole in your up pipe too.
 

Attachments

·
Registered
Joined
·
53 Posts
Discussion Starter #9
Well found out my map sensor was broke off and the o rings on the bridge are bad smh. So I ordered up some new o rings gonna install it right this time, heavy sighs. And yes I made sure to bolt my cap to the cooler mount, I heard they like to break uppipe bellows :)

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
5,778 Posts
Glad you figured out your issue.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #11
I get too excited when new parts come in and I start cutting corners my own damn fault!

Sent from my Zio using AutoGuide App
 

·
Registered
Joined
·
1,173 Posts
I agree with Dustin, your EGR cap is probabaly leaking. Remove it, clean all mating surfaces with brake cleaner and reseal with high temp silicone (orange stuff). I hope you made a cap that attaches to the block where the cooler did too (see pic) or you may have a hole in your up pipe too.
They now have two support holes. :)
 

·
Registered
Joined
·
5,778 Posts
They now have two support holes. :)
So, what does the new one look like?

I ordered mine from you in September, but have yet to pick it up and wasn't sure if I would have the new design or not.
 
1 - 13 of 13 Posts
Top