Chevy and GMC Duramax Diesel Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
6,294 Posts
Discussion Starter #1 (Edited)
electrical issue LLY- Help *UPDATE*

Ok, so my truck has been doing this :cookoo[1]: shit for a month or so.

Randomly all gagues in the cluster quit working EXCEPT RPM and MPH

Radio will cut off and wont turn back on, only lights on the buttons come back

My Insight CTS will cut off and go black, no numbers on the parameters will show up.

I can cut the truck off and turn it back on and it will be fine usually, but the seatbelt light and airbag light will flash constantly no matter what.

Before i take the time of pulling the cluster (time is something i do not have) is there any known problems of wires or loose ground i can check fairly quickly when the problem is ongoing that would cause all but 2 gauges to stop working and turn off my monitor that runs through the OBDII?
Thanks for any advice in advance.
 

·
I'm That Guy...
Joined
·
16,689 Posts
Sounds like a battery, ground or power wire issue to me.

I'd start at you battery and trace power wires for loose connections and then grounds.

Maybe get your batteries tested?
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #3
good advice Tony, i went looking right under the dash. I can test my batteries at school and luckily just started electrical this week in school (diesel mechanics) im hoping to get it figured out and fixed and get credit for this part of the course.
 

·
I'm That Guy...
Joined
·
16,689 Posts
good advice Tony, i went looking right under the dash. I can test my batteries at school and luckily just started electrical this week in school (diesel mechanics) im hoping to get it figured out and fixed and get credit for this part of the course.
The last time I saw a similar issue it was the power connecting to the alternator. Whoever had installed it left the nut loose, it would throw random codes like VSS and have issues with gauges intermittently quitting.
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #5
the only code i have gotten is the bu1626 i believe it was, ill have to make sure tomorrow, i wrote them down at home. something about the theft deturrent system is what it was
 

·
I'm That Guy...
Joined
·
16,689 Posts
the only code i have gotten is the bu1626 i believe it was, ill have to make sure tomorrow, i wrote them down at home. something about the theft deturrent system is what it was
The code wasn't significant, just what started my troubleshooting.

With as many electronics as we have, good connections and grounds are important.
 

·
Registered
Joined
·
1,761 Posts
Def test the batteries, check all your connections and grounds. After I read the OP I thought it could be the ignition switch, heard of them doing some funky stuff. Did a quick site search for 'lly ignition switch', and look what i found lol. I'd say you remembered right, p1626 - Theft Deterrent Sys Fuel Enable Circ. Did you ever change out the ignition switch??
 

·
Registered
Joined
·
1,108 Posts
Grounds, body control module, ignition switch. The usual suspects.

I had a weird problem with my stereo, and cluster. It was throwing a body control module code, turned out to be a grounded wired in my cigarette lighter. Didn't even pop the fuse.
 

·
Registered
Joined
·
726 Posts
Look under the driver seat I had a short in the main harness that did the same thing to my truck.
 

·
Banned
Joined
·
5,738 Posts
Do you have an aftermarket stereo? If so what adaptor harness did you buy?

On the drivers side under the e brake there is a fuse box. I have had a few customers with a short in the harness feeding this panel. The harness rubs on the bare metal of the cab and shorts resulting in all types of wierd issues.

Also take apart your underhood fuse panel and check for critters makeing a home.
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #11
I'm replacing the batteries now since I was planning on it before winter. I will check the the harness, I checked the fuse box yesterday when I pulled my trailer brake out but thanks for the tips. I will re check.

And also to the earlier post yes I looked Into the ignition switch. That was the first thing I checked when the problem first showed up
 

·
Registered
Joined
·
602 Posts
Had this same thing happen to my truck. Took it to the dealer cause it was still under warranty. They found it was a wire under the drivers seat had worn down and grounded itself from the power seat moving back and forth. Fixed the wire and tied them up. No problems since.
 

·
Registered
Joined
·
602 Posts
I'm really not sure. They just said it was one under the seat. But I could not move my seat at all. Seat earners didn't work and the cigarette lighter and power port didn't work either. I was just sayin to double check down there since we had very similar issues. Sorry I can't be of more help.
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #15
Grounds, body control module, ignition switch. The usual suspects.

I will check the bcm. Anything more specific as to where to look for the "grounds" Like i said, i am working with 80+ hour weeks at the moment so sitting around scratching my head, running out of places to look is getting old

I had a weird problem with my stereo, and cluster. It was throwing a body control module code, turned out to be a grounded wired in my cigarette lighter. Didn't even pop the fuse.
I will check that tomorrow as well.

Look under the driver seat I had a short in the main harness that did the same thing to my truck.
Which harness is this ? I looked under the seat and slid it back and forth but from what i can see, nothing is rubbing anything. The whole seat moves on the bracket that holds the seat and no wires were rubbing anything.

Do you have an aftermarket stereo? If so what adaptor harness did you buy?

On the drivers side under the e brake there is a fuse box. I have had a few customers with a short in the harness feeding this panel. The harness rubs on the bare metal of the cab and shorts resulting in all types of wierd issues.

Also take apart your underhood fuse panel and check for critters makeing a home.
thanks, all audio is stock. I will check the fuse under the parking brake. The fuse box under the hood is clear, i check every damn fuse a month ago
 

·
Registered
Joined
·
726 Posts
Push the seat forward and look on the floor under the seat for a rectangular plastic cover if you pull that cover there is a connector for the seat harness the ground in that harness shorts supper ease.

Off topic but I would like to know just out of curiosity how in sam hell did you get Bobo to tune for you? The reason I ask is because I tried to get him to tune my truck this spring could never get a hold of him. I pulled every string I could he wouldn't do it. I mean no disrespect he's VERY GOOD at what he does I'm just jealous.
 

·
Registered
Joined
·
12,050 Posts
your cts may be the cts itself or the version. mine will go black while driving. tap the screen and it comes back on. and also sometimes my TFT and ECT will be blank with just three dots in them. just something to think about idk if its same problem as yours tho
 

·
Premium Member
Joined
·
1,040 Posts
Not positive on this but didn't they have a wiring rub issue some where up by the fuse panel under the hood.Not sure of this but I can recall a lot of trucks with this problem.
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #19
Push the seat forward and look on the floor under the seat for a rectangular plastic cover if you pull that cover there is a connector for the seat harness the ground in that harness shorts supper ease.

Off topic but I would like to know just out of curiosity how in sam hell did you get Bobo to tune for you? The reason I ask is because I tried to get him to tune my truck this spring could never get a hold of him. I pulled every string I could he wouldn't do it. I mean no disrespect he's VERY GOOD at what he does I'm just jealous.
thanks ill try to get that done on lunch at school tomorrow.

He tuned my buddies 06 LBZ and i wasnt happy with my first tunes i had from another source, so my buddy wes called him one night, i talked to him and he ended up doing my tuning. At first its kind of hard to tell how to take Bob lol. He really is a good dude, excellent tuner and has been up late on the phone with me before. Im curious as to what he told you or if you spoke to him directly. Last i heard from him he is having some personal issues i would rather not disclose at the time, it could have been going on when you were trying to get him to do your tuning.
 

·
Registered
Joined
·
6,294 Posts
Discussion Starter #20
your cts may be the cts itself or the version. mine will go black while driving. tap the screen and it comes back on. and also sometimes my TFT and ECT will be blank with just three dots in them. just something to think about idk if its same problem as yours tho
I have already had this one updated and fixed
 
1 - 20 of 34 Posts
Top