Chevy and GMC Duramax Diesel Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Im new here. Maybe a Mod can help put this in the proper place.
I have read many threads on multiple Dmax forums but have been away for awhile as my truck was running excellent. And i'm back, i started a new account and still have yet to finger out how to do my signature and am unsure where to post my problem. This is my second Dmax, I also have an '03 LB7 120Kmiles CCLB 4x4 6" Fabtech with EFI Live
I have a 2006 Chev Silverado 2500HD (102kmiles)LBZ CCLB 4x4 6" Fabtech EFI Live DSP5 CTS2 with All LED lights. I've had it a year.
Recently ive noticed a fast flash developing in the signals. Anyway i was installing the new 2015+ Spyder Mirrors w/reverse lights (should have gone boost mirrors)on the LBZ and put the LBZ mirrors on my LB7( which are bitchin" and work great). I pulled the wire thru the doors and spliced to a wire i ran to the underhood fuse block(b/u trlr) where i tapped power. when i put it in reverse, it blew the 10amp fuse, not having a 15 i put in a 25amp. (Idiot) Now i have no power at Trlr B/U but i do at (B/U) and my reverse lights dont work. No power under dash on green wire for trailer either. No power under underhood fuse block for b/u trlr either. What burnt? BCM reflash needed? PRNDL works. hmmm?
Now i learnt after installing the mirrors and reading some forums about the dual function of both the reverse lights and the signal/drl, ill wiring that up using the correct wire harnesses from boost after i finish [email protected]#king this up.
Also i lost my turn signals.lol. wtf? Hazards work on the driverside only. right turn fuse keeps blowing. not the bulbs right? i swapped flasher from LB7 (which works) into LBZ same thing. not the flasher then right? Short? where? The truck was allLED when i bought it. Do i need the GM 10383322 ($78) LED flasher from Rock Auto?

Thank you in advance.I look forward to yalls help.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #2
Oh and I'm throwing codes
P0381
P0646
P0650
P2563

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Bump

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
Ok. TBC 2C fuse was out. Got bu lights to work on truck. But b/u on mirrors keeps blowing fuses. Not seeing a short anywhere...

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Pretty sure the short was inside the brand new passenger Spyder mirror. I unplugged that mirrors b/u light and just went with the driverside plugged in and it worked......plugged the passenger in and blew a fuse. So I'm trying to warranty it. Meanwhile I put the old tow mirrors back on and turn signals are messed up. Trying to post a video....

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
Still believe it's a bcm problem. Looking at going to the stealership Monday for a talk...

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
So my symptoms are key on lights off, left signal on......outer marker lights flash on both sides in front and small corner light 194 on opposite side flashes, mirrors flash correctly.

Operates the same with right signal on except in fast flash and tail light inner and outer flash opposite on right side.

Attached is something I read that resonates.....

Gonna replace my flasher module with LED compatible one.

Thoughts?? Screenshot_20190630-195554.jpg

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
4,933 Posts
So my symptoms are key on lights off, left signal on......outer marker lights flash on both sides in front and small corner light 194 on opposite side flashes, mirrors flash correctly.

Operates the same with right signal on except in fast flash and tail light inner and outer flash opposite on right side.

Attached is something I read that resonates.....

Gonna replace my flasher module with LED compatible one.

Thoughts?? View attachment 1041039

Sent from my Pixel XL using Tapatalk
your turn signals are not running on AC, and they are not switching polarity (and your reverse lights are certainly not either), so having a diode is not the issue as mentioned in that post. A diode will only block flow in 1 direction, so if the LED lights up at all it is installed in the correct orientation for a DC system. I recall not too long ago another member just happened to get a dud mirror from the factory, it had an internal short and kept blowing fuses, the cure was to RMA the bad mirror for a new one. you could disconnect the mirror harness, and meter the 2 wires for the circuit you are blowing the fuse for. You should be able to check for continuity, if not, try reversing the wires (a diode will block the continuity check if its opposing the direction of flow). in continuity mode most meters will also give you approximate resistance of the circuit. the resistance depends on how the LED;s are configured, but it should not be a very small number.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #10
I forgot to mention my results with lights on....
All lights work as intended except fast flash on right side and right tail light inner and outer flash at opposite times.



I've re installed the factory mirrors and am not blowing fuses at the moment. The reverse lights are working.

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
4,933 Posts
I forgot to mention my results with lights on....
All lights work as intended except fast flash on right side and right tail light inner and outer flash at opposite times.



I've re installed the factory mirrors and am not blowing fuses at the moment. The reverse lights are working.

Sent from my Pixel XL using Tapatalk
im going to guess the mirror is not properly assembled and has an internal short. Maybe a couple wires got pinched together, or maybe a solder blob is shorting something out, you can use a meter to check the mirror out, but i would give the manufacturer a call or email and see if they will just send you a new mirror, it sounds like its just the one mirror.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #12
I'm working with Duramax store and the manufacturer of the mirror to get a replacement sent meanwhile maybe you can walk me through checking out the mirror?

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #13
Also I took the LED 194's out of the lil corner signals and put regular bulbs in. No difference.

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #14
I take that back. After switching to regular bulbs on corners.....both corners blink on either signal.

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
45 Posts
Discussion Starter #15
Also the front bottom inner lights are still incandescent dual filament bulbs which are the only regular bulbs in the truck. Gonna swap them out for LED's when I get the new flasher.

Sent from my Pixel XL using Tapatalk
 

·
LHN...We ARE the Joneses
Joined
·
26,485 Posts
The 194 bulb is a parking light that goes off when the signal is on....resulting in an on/off flash, but it's not a signal flash, it's a parking light going off.
 
  • Like
Reactions: KdNicoll

·
Registered
Joined
·
45 Posts
Discussion Starter #17

·
Registered
Joined
·
45 Posts
Discussion Starter #18

·
Registered
Joined
·
45 Posts
Discussion Starter #19
What button do you gotta push to get these lights working. Never seen mine on. (Marked in red).


Sent from my Pixel XL using Tapatalk
 

·
LHN...We ARE the Joneses
Joined
·
26,485 Posts
And you won't see 'em....not from the Driver's Seat.

Those are your Daytime Running Lights....there is no 'ON' button.
They come on when you shift out of Park (if the dusk/dawn sensor sees Daylight)....so drop it to NEUTRAL (so you don't run over yourself in R/D), set the brake and step out for a look-see.
 
  • Like
Reactions: KdNicoll
1 - 20 of 42 Posts
Top