Chevy and GMC Duramax Diesel Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
So I put full 4 inch exhaust on my truck and now I am getting a engine code its a exhaust rescirculation code or something?
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
its a 2005 lly by the way and I deleted it before I wrote it down and someone was talking to me but its happened 3 times now and when it comes on I loose power
 

·
I STILL DGAF
Joined
·
9,061 Posts
And you're getting reduced power when it comes on? My lbz threw that code constantly until I got EFI live and I never had any issues with reduced power. Brothers lly is the same. Hmmm.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #7
I thought it was the edge juice so I took it back and now I got that code again
 

·
Registered
Joined
·
68 Posts
Discussion Starter #9
maybe it doesnt but kinda feels like its not 100% only when that code comes on I just have a air raid intake and turbo back exhaust
 

·
I STILL DGAF
Joined
·
9,061 Posts
Yeah I think maybe the light is throwing you off. Insufficient exhaust gas recirculation is no biggie. It just throws the light and that's it. You can get a fingerstick to take care of the light.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #11
I am getting 0401, 0404, 0299 all three codes and yes its making my truck loose power anyone know whats causing this
 

·
I STILL DGAF
Joined
·
9,061 Posts
Check for boost leak also, since you're actually losing power. Sometimes the 0299 pops up but doesn't affect performance. Not in your case though :(
 

·
Registered
Joined
·
68 Posts
Discussion Starter #17
I don't know cause I took off my cat and all these problems started right after I thought it was the edge w/juice so I removed that and got the codes again. I took it to a diesel shop and he said my egr is probably shot but never mentioned anything about boost leak he said the one problem is making all my codes and I did put a new air raid intake on could that have cause my map to get dirty maybe?
 

·
I STILL DGAF
Joined
·
9,061 Posts
LOL, nope not me. The 0299 is what's causing power loss. You might need to rescale your maf or you might have a boost leak (doubt it though). This shit is very common after exhaust and intake on the LLY. EFI Live can take care of it all though. Rob @ ATP can hook you up.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #20
I am pretty sure no boost leak dont hear one but not sure were to look lol I guess I could just do the efi live and see if that takes care of it
 
1 - 20 of 24 Posts
Top