Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
HI I have a 2004 2500hd with lly. It has the edge juice with attitude magnaflow 4 inch exhaust and an AFE intake. When I lay into the throttle even on stage 1 I sometimes end up in limp mode. I know that there are a number of things that can cause this but I was under the impression that I would get a check engine light and I'm not. Should I just start with the fuel filter or is there something else going on.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
YOu dont always get a CEL for a p1093 code which is low fuel rail psi during power enrichment mode. How old is your fuel filter? how many miles on it?
What year and trans is your truck?

Later
Caleb



MODS, THIS Should be moved to its right engine code forum!!!!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the reply. I just checked I have 21000 kilometers on it, I think I will start with the fuel filter.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
Yes thats were i would start for sure, the filters are way undersized for the engine and need replaced quite often, i change mine @ about 7,000 miles and some even sooner due to poor performance befor 7k!!! One bad tank of fuel will ruin a filter.

Good luck,
Caleb
 

·
Registered
Joined
·
47 Posts
This is great. I needed this info for my 05 LLY that I just bought. I bet that the fuel filter has not been changed recently. I will post after I change it and try the CL setting
Thanks 05 LLY for the dtc. I could not find that one in the Bully Dog dtc book.
 

·
Registered
Joined
·
47 Posts
Caleb,
I have read several other posts that you have given advice on and I am sure my problem is the fuel filter. The trouble codes are 1092 and 1621. The 1621 is "Control Module Long Term Memory Performance/ Immobilizer Code Words Do Not Match" I don't know what that one means. If anybody does please let me know.
Thanks,
Bruce
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
I would ignore the 1621 for now, clear the codes and see if it comes back, if i dose, i would say its either a issues with you programer, or a bad ecm, the code breakdown i have of it pretty much points at a bad ecm, but i'm sure in their wrighting the breakdown they werent considering flash programers!

Good luck and let us know how it works out!
 

·
Registered
Joined
·
47 Posts
Yes the 1621 came back with the 1093 during hard acceleration. I am going to try the other download without the Crazy Larry. Yeah, I'm positive they weren't writing for flash programmers.
Again, thanks, Caleb
 

·
Registered
Joined
·
20 Posts
Even after changing the fuel filter and truck completely stock does it still code 1093? I had the same problem took it into the dealer they ended up changing the fuel filter twice because they said it was bad fuel. I ended up installing a 2nd inline filter up stream of the factory one just to convince them that wasn't the problem. After this they ended up changing 2 injectors, fuel sensor and fuel regulator, which finally fixed the problem. A number of Different things cause code 1093, do your research and you'll be better informed when you take your truck into the stealer!!:cool:
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
1093s can be caused by different things but more common than not it is from big hp programs draining rail psi, and a bad filter will just add to the problem!!!! in your case i would say you had a bad fprv!
 

·
Registered
Joined
·
47 Posts
The 1093 did not come back after the filter change. However today I installed the Outlook that came with my Triple Dog and when I selected the '05 from the list it gave me Dodge selected and froze. After that I got several DTC's and the CEL came on and stays on now. The DTC's are P0238, P0700, P1621, P1626, U0073, U0101, U0105. I know what the P codes are but not the U codes. I have removed the download from the truck and unplugged the Outlook but I still get the P0700 everytime I read the DTC's and the CEL stays on now. I am going to post a new thread for this to see if I can get some input.
 

·
Registered
Joined
·
20 Posts
P0700 refers to the code set in the TCM, maybe something wrong with the tranny. Where in alberta are you located?
 

·
Registered
Joined
·
47 Posts
Thanks for the link to the codes. I have contacted Bully Dog and they figure they have a few Outlooks out there that were wired wrong and this was happening. I will have to go to the dealership to have this one reset I figure though. I am in Lloydminster Alberta. Where are you? I got my triple Dog from NADP in Edmonton and they have been real helpful.

Bruce
 

·
Registered
Joined
·
20 Posts
Sherwood Park, I thought if I was near enough I could have helped you out.
Rich
 

·
Registered
Joined
·
47 Posts
I have removed the Outlook monitor and I am sending it back for replacement.
 

·
Registered
Joined
·
96 Posts
u codes are loss of communication in the serial data lines. i didn't look up the specific codes but i'm betting that basically your tuner probably did it. it caused several of the modules to not be able to communicate with each other when they knew they should be communicating with each other. they'll move to history status in a bit and eventually clear themselves.
 

·
Registered
Joined
·
47 Posts
Thanks, I've got all the codes now and the truck is back to normal. I'll see if the new monitor does the same and if it does I'll have a Triple Dog on eBay. I was able to clear them with the Bully Dog, Triple Dog. The CEL would not clear though. I disconnected the batteries and it was still there but after driving for 45 minutes the CEL went away. WHEW!
 
1 - 19 of 19 Posts
Top