Chevy and GMC Duramax Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hay boys this is larry. I have a 2005 lly d-max that I bought 6 days ago. ran great for 2 days now it has a bunch of problems. It has an edge juice, cold air and a 4" exaust. I am getting really high egts (2200) and also pressure building in my cooling system. my egts are so high that my truck defuels and i have a huge loss in power. I have also had my truck go in to limp mode when i pass a car after i have been driving over an hour, hopefully the filter fixes that. I have no codes so I cant figure out whats wrong. I have ordered the egr delete today. has anyone had this same problem or maybe know how i could fix it.
 

·
Registered
Joined
·
2,538 Posts
what tune are you running it on?

Is there any coolant in your oil? When the truck is running take off the coolant reservoir cap and see if there are any bubbles coming up. Also, after the truck has cooled down over night, check the upper rad hose first thing in the morning to see if it is still hard (it will feel like a tennis ball). LLY's have a history of head gasket issues, and beating on the truck and running it that hot could sure bring the gremlins of them out..

My guess is you're limping your transmission by running too high of a tune. When you're passing the car are you in 5th shifting down to 4 by chance? No fix to it on a 5spd allison like we have. You just need to start saving for a transmission build.. it will only happen more and more often and get progressively worse.
 

·
Registered
Joined
·
2,334 Posts
2200*???? man i really hope you don't/haven't melted your pistons or started too
 

·
Registered
Joined
·
2,538 Posts
Meant to ask earlier.. is this peak temp? Or how long are you holding it there for? few seconds? more, less?
 

·
Premium Member
Joined
·
1,972 Posts
Hay boys this is larry. I have a 2005 lly d-max that I bought 6 days ago. ran great for 2 days now it has a bunch of problems. It has an edge juice, cold air and a 4" exaust. I am getting really high egts (2200) and also pressure building in my cooling system. my egts are so high that my truck defuels and i have a huge loss in power. I have also had my truck go in to limp mode when i pass a car after i have been driving over an hour, hopefully the filter fixes that. I have no codes so I cant figure out whats wrong. I have ordered the egr delete today. has anyone had this same problem or maybe know how i could fix it.
Just wondering how many miles are on the truck.....Sorry to say, but most likely it had the same problems before you purchased someones else's problems....
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
stock settings and no oil in coolant and no coolant in oil. builds pressure cold, I think that boost is leaking in the egr system. its limping the engine because it only gets 2000 rpm, not locking in gear. Its been doing this for a few days and has only spiked over 1350
never held over 1000 for more than 1 sec. I have only drove it to see if what i have done changed anything
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7 (Edited)
Im pretty sure i havent caused any problems. thay came with the truck. the truck has 150k. the dude said it has a new inj. pump and tranny. but he also said it was a good truck with no problems. when it went to limp mode it never shifted down. I just eased it up to 80 mph and when i slowed back down to 70 i touched the throttle and nothing there. i even unpluged the chip completely stock and it still done it
 

·
Registered
Joined
·
6,215 Posts
2200*???? man i really hope you don't/haven't melted your pistons or started too
Iirc the melting point of steel is around 2500..that means with time and a few hundred more degrees that motor will be liquid..if it gets above 1800 it's generally in your best interest to stop driving and let it cool a bit..Hell, 1600 is still cookin!
The temps in your engine are a little higher than they are at the exhaust manifold as well, so..

Id start with removing the edge and see if that helps, less fuel will get you lower egt's.
 

·
Registered
Joined
·
6,215 Posts
Im pretty sure i havent caused any problems. thay came with the truck. the truck has 150k. the dude said it has a new inj. pump and tranny. but he also said it was a good truck with no problems. when it went to limp mode it never shifted down. I just eased it up to 80 mph and when i slowed back down to 70 i touched the throttle and nothing there. i even unpluged the chip completely stock and it still done it
Didn't see this^^
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
found the problem. The egt probe for the edge is bad and head gaskets. $4500.00 to $5000.00 to fix it at gillette diesel in draper ut.
 

·
Registered
Joined
·
7,819 Posts
that's a lot of coin...

check into doing it yourself.

Edge Juice tuning is pure shit. ditch that in the future.

do ARP studs and grade C gaskets
 

·
Registered
Joined
·
7,819 Posts
post in the vendor jungle and they'll shoot you their best prices. it's good to support them and they're generally the least expensive route to get it done right.

h&s some people like them, i've read they run hot.

EFI is the way to go, behind that I think edge evolution/PPE
 
1 - 15 of 15 Posts
Top