Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter · #1 ·
So I live in Illinois and its been roughly in the 30's at night, but I've found that my truck doesnt like to start up after work on 2nd shift or in the mornings unless I have the block heater plugged in then it starts right up. The fuel filter only has 1000 miles on it and is a Fleetgaurd brand which is what Cummins makes and uses on their semi trucks and such, a very high quality filter. I currently have a full tank of fuel from the same station I always go to and the station is even only 6 months old. Any ideas why I would have the extended cranking?
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #2 ·
Bump guys any help here?
 

·
Registered
Joined
·
71 Posts
How long does it crank before starting? Does it smoke or run rough once it starts? Has the SES light been on at all? I'm wondering if you have a glow plug issue? Usually this throws a code though.
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #4 ·
Last week there was a night I didn't plug it in after getting home from work at 1am and it was in the 30s, went to start it about 10 am and couldn't get it started. The mirror said it was 34 degrees. I plugged it in for an hour and a half and it started right up. I haven't seen any check engine lights though. Usually the times its extended cranking it may take 2 or 3 tries at it before it starts. Never have a problem when it's plugged in so could be glow plugs
 

·
Registered
Joined
·
12 Posts
I am having this same problem with my truck, was just about to make my own thread hope you dont mind if i post up my problem as well?

2003 Duramax LB7 all 8 injectors done less then 2000 miles ago, brand new glow plugs 2 days ago. Truck starts if its plugged in no matter what. But if its 8*C/46*F or colder it will not start unless plugged in. If its a bit warmer then that and not plugged in it will start but it does crank for 5-6 seconds before it fires up and puffs a bit of smoke. Once its been started and it will start normal all day as I drive around town once the engine is warm. Leave it over night and it will not start unless plugged in.

Thanks for any help. Im thinking 03maxin and my problem may be the same?
 

·
Registered
Joined
·
58 Posts
Check your batteries. I had same problem, hard start when cold easy start plugged in. I found one of the batteries had a dead cell. replaced the battery, now it cranks twice as fast. starts every time even when not plugged in. I never realized that it was turning over so slow till I put the new battery in it.
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #7 ·
Check your batteries. I had same problem, hard start when cold easy start plugged in. I found one of the batteries had a dead cell. replaced the battery, now it cranks twice as fast. starts every time even when not plugged in. I never realized that it was turning over so slow till I put the new battery in it.
I'll look into that, as far as I can tell it cranks just fine and I know the batteries aren't that old but I will check it out. Thanks for the idea:thumb I haven't had it plugged in while at work (430pm-1am) last few nights and started up just fine, and Im not plugging it in tonight being that it is 40 outside right now so we shall see what the result is tomorrow.
 
1 - 7 of 7 Posts
Top