Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Wondering if anyone has had any weird "drops" in oil pressure readings?
With the truck (2004 LB7) running for about 2 hrs of straight hi-way driving, a glance at the gauge showed NO oil pressure. There were no "telltale noises" from the motor, but I pulled over anyway. Oil level was slightly down (normal), no traces of a leak from the recent filter change, no oil on the undercarriage....

Restarted the truck, and all was fine. Drove the remaining 45 minutes w/no other issues. No oil pressure warning lights ever came on (not sure if there are any), no "oil level low" light came on, so I'm thinking its a sending unit or ?gauge? problem. Any experiences??? suggestions???

BTW, truck has 47K on it, and I've had it 3 months. Any assistance would be appreciated.

thanx,

Steve
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,163 Posts
Could have just been a problem with the instrament cluster its self, they have been know to have problems in some trucks!!! Keep an eye on it if the psi was low it should throw a low oil pressure warning!
 

·
Registered
Joined
·
41 Posts
My 01 sticks at 40 ish a lot. Especially when I turn the truck off. Some times its sticks while running but when i hit it hard to where the pressure jumps quicks it "breaks loose"
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
update

Went to the chevy dealer today and found after some discussion:

motor is still covered by warrantee w/$400 deductible

oil pressure sending unit is $75, and controls both gauge and idiot light/bell

idiot light doesn't come on when pressure drops

...

therefore - sounds like gauge issue

ps - they wanted me to leave truck so they could evaluate problem, i.e. drive truck around/let it run for 1 & 1/2 hrs to "make" condition occur... probably not!!

...No decision for now
 
1 - 5 of 5 Posts
Top