Chevy and GMC Duramax Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
We bought a 06 LBZ. It had around 30,000 on it when we got it. We have a rattle vibration type feel in the front end. It seems to be most noticeable when pressing the brake pedal while turning a curve. We took it in and they replaced the intermediate steering shaft. That didn fix it. We have took it in around 4 times now. They say they dont know what it is. They did notice that the torsion bars had been bumped up and said that might be causing the the problem. So now that the torsion bars are put back down it still does it. They said it couuld need an alinement. So its in right now getting that done. Anyone else have this problem??
 

·
Diesel Addict
Joined
·
7,754 Posts
check the rotors and brakes but before you do that have the tires rebalanced and rotated..
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
We just had new tires put on. It did it before and after that was done. They ordered new torsion bars for it. The dealer said they started adjusting them back and one of them started sagging. Maybe that could be the vibration. I dont think it has to do with the brakes. You can actually hear it from time to time. Maybe the t-bars will fix it. Just have to wait and see.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #4
Any Suggestions????:confused::help:confused::help
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
68 Posts
I have an 04.5 LLY 2500 CC and it does the same thing you described. Kinda' makes a thumping sound when slowing down and turning. No _bad_ vibration, but it is evident and sounds like you are going over bumps. It's time for some filter changes, so I was gonna ask them when I go in.........
 

·
Registered
Joined
·
275 Posts
Discussion Starter #7
4x4 partially engaged???

We have an 06 2500hd Duramax. We have been have a rattle in the frontend. The dealer has been over it like 6 times now. they replaced the int steering shaft and the torsion bars. it still does it. i think its the 4x4 partially engaging. the other day it started the noise and dad hit the 4x4 switch and it smoothed out. so for some reason it seems that its partially engaging when its not supposed to. Has anyone had this problem before? what would cause this and can it be corrected? that warranty is up but they agreed to fix the problem because it was took in b4 the warranty was up. any help would be appreciated. thanks guys
 

·
Registered
Joined
·
47 Posts
I have a rattle in the front end of my truck when I hit bumps on the road, but when I lightly apply my brakes, the rattle goes away. This happened from driving down bumpy gravel roads and the pins wear out in the sleeves in the calipers. Then the caliper brackets will slightly spread due to the oblonged sleeves. This is not covered by warranty. I was told that all brakes assembly parts are normal wear and tear items. I was told to remove my calipers and use RTV silicone on the brackets then re-install the calipers.
My last truck used to make the same noise as you describe and it turned out to be the bearings in one of the front wheel hubs.
 

·
Registered
Joined
·
23 Posts
I just had mine in the shop for this problem. It sounds like a popping sound that comes from the right side. You can even feel it through the floor board at times. Sometimes its louder than other times as well. It only happens when turning. They replaced some "body bushings" and shock covers. This did not fix the problem either. So I guess I will be taking it back in before the warranty runs out in about 6k.
 

·
Registered
Joined
·
1 Posts
I have mine booked in tommorow for the same problem and they claim it may be a bearing on the steering shaft?
 

·
Registered
Joined
·
275 Posts
Discussion Starter #11
yep thats the sound. its mainly when making turns. its a popping flapping thumping type of sound. and you can even feel it in the floor board at times. like i said. the put new torsion bars and intermediate steering shaft on it and even done a alignment on it. it still has the same problem. they told us it may the the step bars on the sides of the truck:rolleyes: took them off and there was the sound once again. they have been over the frontend multiple times. its back in the shop again. we made mention this time that it may be the 4x4. because you can put it in 4x4 and at times it will stop the noise. so maybe that will lead them to check it out. we are gettn impatient but on the bright side atleast we are gettn a bunch of new parts.:D
 

·
Registered
Joined
·
275 Posts
Discussion Starter #12
well after all this trouble the problem still aint fixed. and they pretty much said they cant fix it.:rolleyes: so i guess we will just have to live with it.
 

·
Registered
Joined
·
93 Posts
yes, if the intermediate shaft didn't fix the problem, a problem that the dealer should be aware of ,is a worn bearing at the bottom of the shaft where it connects to the box. I had this problem last week when i recieved a recheck and looked at Service Info( i'm a mechanics helper at a dealer)The 1/2 tons are not effected like the 3/4 and 1 ton trucks are!
 

·
Registered
Joined
·
26 Posts
Check the CV joints, you my have a dry u-joint under the boot. It will eventually seize but you can buy CV joint grease for it. You'll need a grease gun and needle grease tip to apply under the boot. If that doesn't help then you'll have to replace the joint assembly! Its not that hard to do, an hour or so and about $150 for the parts.
 
1 - 14 of 14 Posts
Top