Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
260 Posts
Discussion Starter #1
Ok 04 Lb7 mods in sig. Few days ago started it up and after about 10 min of idle in started sounding like a powerjoke. Got P0088-89-90 codes and 1940 rpm limiter. I always run diesel kleen and fuel filter is 3k old. Well I logged it with Efi and cts. Desired rail psi is normal but actual is 25-26k no matter what. I figured stuck open fpr. Is there a way to take apart and clean it or just buy a new one? Gonna tear apart in a few days just looking for some insight. Thx guys.
 

·
Banned
Joined
·
5,738 Posts
If your desired is correct and the actual is fucked then it is most likely the fpr, but logg your fuel rail pressure sensor first to ensure it is functioning properly.

Your FICM maybe bricking on you also................
 

·
Registered
Joined
·
260 Posts
Discussion Starter #3
I did log it. Ill have to ck the log in the morning to see voltage. I believe it wad like 1.5 volts but not sure. Thx for the reply smokinLmm.
 

·
Banned
Joined
·
5,738 Posts
Let me know and I will compare it to another LB7 that runs correctly.
 

·
Registered
Joined
·
260 Posts
Discussion Starter #6
Ok so I logged the only pid that it shows which is fpr current it is at 1.49 Amps. I logged my 01 LB7 and it also is 1.47-1.49 Amps. I did not show rail pressure sensor on the LB7 pid list. So im thinking replacing the fpr is in my near future. The for your help Smokin...
 
1 - 6 of 6 Posts
Top