Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Ive had this problem 2 days in a row now.. 03 LB7 ..... gauges don't register when key is switched on... even after cranking.. have wiggled key bumped dash & nothing... about 2 min in to my drive they come alive.. any body have this problem?.... any advice?
 

·
Registered
Joined
·
5 Posts
Same problem

Having the same problem 03 GMC LB7. Had to replace Alternator. The one they put in was causing severe voltage fluctuating. Had it replaced, now cluster lights and gauges delay when starting. Takes about one minute for them to come on.
 

·
Registered
Joined
·
262 Posts
Common problem. Simple Solution.

Ive had this problem 2 days in a row now.. 03 LB7 ..... gauges don't register when key is switched on... even after cranking.. have wiggled key bumped dash & nothing... about 2 min in to my drive they come alive.. any body have this problem?.... any advice?
This is the typical symptom when the batteries need replacing. It might also be your alternator.

Go down to Advance Auto and they'll test your electrical system (alternator, batts, etc) for free.
 

·
Registered
Joined
·
262 Posts
Yes. Bad batteries and alternators can cause the cluster to not boot. The easy solution is to have the entire electrical system tested (FOR FREE) at places like Advanced Auto.
 
1 - 5 of 5 Posts
Top