Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
So my truck has been getting a code p670 code says glow plug control and also a p0045 code that sounds like the vane position sensor is reading wrong or the vanes are stuck. I got off the bus from work this morning and it just cranked and cranked trying to start. It was 19* and its never missed a beat even in -30* this winter. So i was wondering if im leaning in the right direction with it being the glow plug control module?
 

·
Registered
Joined
·
3,527 Posts
So my truck has been getting a code p670 code says glow plug control and also a p0045 code that sounds like the vane position sensor is reading wrong or the vanes are stuck. I got off the bus from work this morning and it just cranked and cranked trying to start. It was 19* and its never missed a beat even in -30* this winter. So i was wondering if im leaning in the right direction with it being the glow plug control module?
Yes I would check the glow plug module. Also try a WOT run at engine temp to try to clean out any carbon that would make the veins stick...


Sent from AutoGuide.com App
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #3 ·
Fixed.it was the glow plug controll module
 

·
Registered
Joined
·
215 Posts
Mine is doing the same if I don't let it warm up its throws those codes if I let it warm up its fine you think mine is the same issue
 

·
Premium Member
Joined
·
17,806 Posts
Moved to LLY
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #6 ·
Mine is doing the same if I don't let it warm up its throws those codes if I let it warm up its fine you think mine is the same issue
Yea most likely. Thats how mine was.fhen one day it wouldnt start unless it was plugged in. Now i have no problems again.
 

·
Registered
Joined
·
231 Posts
cheap easy fix. I did this last year on my LLY. Dealer has part forabout $70 if I remember correctly... glad you got it fixed!
 
1 - 7 of 7 Posts
Top