Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
680 Posts
Discussion Starter · #1 ·
I have an lbz with just under 6k. The past week or I have noticed the glow plug light not lighting up, upon first start up, and engine is cold. Has anyone experienced this? Was wondering if there is a recall, tsb, or reflash for the glow plugs. Or if it is normal, the plugs don't have to heat up do to outside ambient temperature? Also, here an abnormal tick from lower end of engine, form pan area, while engine is idling in park its more noticeable.
 

·
Registered
Joined
·
699 Posts
i have an 06 lbz new about 2 months ago and i have never even seen the glow plug light to know where it is " gotta love florida", haven't herd anyone around here with a ticking noise, sorry
 

·
Registered
Joined
·
40 Posts
I noticed at around 85 degrees and above the glow plugs don't kick on, and for the tick its normel
 

·
Diesel Addict
Joined
·
7,754 Posts
the LBZ has sevaral dealer upgrades avalible and the one concerns the glow pluggs but i personally never had any trouble but i had my LBZ upgraded..
 

·
Registered
Joined
·
680 Posts
Discussion Starter · #5 ·
Thanks for the info, I think the glow plug did not need to heat up for start where I live,due to how hot it is. Went out of town to the ocean where it is a lot cooler, let my truck sit overnight went to start it, glow plug light came on.
 
1 - 5 of 5 Posts
Top