Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 19 of 19 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I had a lot of luck fixxing previous problems on here, figured id try again. I heard the gauges on the newer chevys are crap. That being said, my temperature gauge wont zero completely when the trucks cold. This is makeing my glow plugs run as if the truck were warm when its actually cold. The gauge works, but acts as if 160 is zero. I replaced the ect sensor and that didn't help. Any ideas??
 

·
saw what you did there
Joined
·
14,297 Posts
1. what year is your truck.
2. the glow plugs dont' interact with the ECT gauge at all.
 

·
Registered
Joined
·
1,727 Posts
Mine work just fine and my temp gauge sits on 160 as if it were zero. Might be your glowplug controller.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
The truck is an 04. The only reason I brought the gauge up is because it use to sink the whole way down. But now it don't. Didn't know if the two was connected
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Yes. The main check engine light is on but my diagnostics didn't tell me squat. The light was on before all this gp stuff happened
 

·
saw what you did there
Joined
·
14,297 Posts
OK, here's what you do. Go stop by any autoparts store, and ask them to read your code for you (it's free) and then make sure you write down what the code is, come back and post it up.
 

·
saw what you did there
Joined
·
14,297 Posts
P0380 Glow Plug Control Module.

P0540 is Intake Air Heater Module

P0401 is an EGR code.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
Egr is blocked, and I'm jus curious, would a cold air intake possibly affect the intake air heater mod? Glow plug control mod locale?
 

·
Registered
Joined
·
1,727 Posts
Both the glow plugs and intake heater work off the same fuse, so you might just have a blown fuse.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #14 ·
Pulled the fuse, but the connections didn't look obviously fried. Musta been the problem though cuz I replaced it and the intake heater is working now, and the truck was warm but I'm assumeing the gp's will work as well. Thanks both. I didn't no they were on a joint fuse
 

·
Registered
Joined
·
1,727 Posts
Hopefully that was your problem man. Let us know either way!
 

·
Registered
Joined
·
5,569 Posts
Did the one you changed look like this?

 

·
Registered
Joined
·
20 Posts
Discussion Starter · #19 ·
Replaced the 175a fuse. Intake heater is deffinately working. Its bout 35 degrees outside so wont no about the gp's till it gets cold out. Pretty sure that done it. Thanks for that pic dirtyjeep
 
1 - 19 of 19 Posts
Top