Chevy and GMC Duramax Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
keep getting engine power reduced message. no error codes are popping up it just keeps de-rating the engine and i havent a clue what is going on. i am able to push 32lbs of boost before it derates and fuel pressure is fine. might be a little week on black smoke but they may have been due to it being 30degrees out. it first derated today after i got on it hard then let off and i stayed off the throttle for awhile and it came on. so i turned it off and turned it back on an drove then it did it again at a stop sign and then again when i got home so it is coming on when it is at an idle but i am clueless on why this is happening so any help at all would be appreciated
 

·
Registered
Joined
·
2,500 Posts
Any mods to your intake? Sounds like a similar problem I had with my MAF, though mine was throwing codes with it.
Other then that I have no idea.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
afe cold air intake. but i have had issues with leaks on the air to air tubes before on this truck
 

·
Registered
Joined
·
577 Posts
^wet or dry filter?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
dry
 

·
Registered
Joined
·
2,500 Posts
Is your MAF still plugged in? If not, does your programmer allow you the ability to cut it out of the equation?
Mine had something to do with some sort of parameters of the MAF or intake. I don't really know exactly. I just knew I could take it to ATP and SickDiesel (Dustin) made it go away with whatever EFI magic he worked.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
i believe its still plugged in. i have the black maxx programmer and i dont think i can remove it
 

·
Registered
Joined
·
577 Posts
any codes pop up once it goes in limp?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
nope no codes no check engine light nothing but limo mode with no indicators i can shut if off and it will run fine until i get on it then let it idle it seems every time the reduced engine power comes on it has been at an idle. i would say i have a boost leak but i am able to push 32lbs so i dont think that is the case
 

·
Registered
Joined
·
1,268 Posts
Suscribed
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
did it more today. only does it when its allowed to idle for several seconds...like at a drive thru window or sumthing. any one have any other ideas
 

·
Registered
Joined
·
30 Posts
Discussion Starter #12
i tryed up plugging my my chip and that did not fix lt any ideas?
 
1 - 12 of 12 Posts
Top