Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 12 of 12 Posts

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #1 ·
I just got my gauges and went to install them and the instrutions where horrible no locations on anything no help what so ever.
My questions are: Where is the best place to put the boost probe?
Where is the best place to put the EGT probe at?
any pictures would be a great help to me.
My truck is an 03 LB7
Thank you
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #3 ·
thank you for that thread i did not see it when i was searching for them. will help a ton.
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #4 ·
one more question before i go out and do them... i hear to leave the truck runnins when you do the EGT... true or not true?
and should i take the pikpe off for the boost sensor when i drill it?
 

·
USMC
Joined
·
795 Posts
I left the truck running when i did mine. Helps keep those shavings from going into the turbo. Grease on the bit is not a good idea. Clogs up the grooves and your hole wont be true.
 

·
Registered
Joined
·
393 Posts
Removing the manifold or pipe would be the safeist but most guys drill it while idling.
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #7 ·
ok. even the boost sensor well running too? or just the manifold. i don't want to take that off. the pipe should'nt bo to bad to take off though.
 

·
Registered
Joined
·
2,480 Posts
Post up pics when your done
 

·
Registered
Joined
·
1,260 Posts
ok. even the boost sensor well running too? or just the manifold. i don't want to take that off. the pipe should'nt bo to bad to take off though.
I would take the intake bridge off to drill and tap it. I wouldnt want shavings going directly into my motor. Or you could always buy a SD manifold they come pre tapped but they are around $100
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #10 ·
i willl take pics as i go. ok i will take it off hopefully to do it.
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #11 ·
my set up came with a T for the boost pressure. should i put that infront of the PPE boost increase vavle? and then run off that T the hose into the sensor? mine is digital so it plugs into the back of the gauge. i will try to get pics up. I am very lost on this boost set up. and can't find any pics on it at all. someone please help.
 

·
Registered
Joined
·
2,528 Posts
Discussion Starter · #12 ·
here is what i have. let me know please.
 
1 - 12 of 12 Posts
Top