Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
:helpi have a 2005 duramax last wed i was driving i looked down and my temp was at 250 i stoped and checked it out lower hose was cold as ice top hose was 215 according to my infared temp gun a month earlier i changed the water pump and all has been great ,so i changed the thermostats oem still same prob vacumed the cooling system down and filled the coolant when idling truck is 210 and will stay there all day i also changed the temp sender and the fan clutch i have no heat and when driving full throttle or under load i start to over heat i cannot figure it out and is starting to make me mad today i pulled the heater core hose off the egr cooler and i had no flow do u think mayby the pos water pump from pep boys impeller came off please help

thanks anthony
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
i changer thermostats with oem and i do not have flow when i pullet the heater core line it dribbled out and my lower hose is 75 degrees upper hose 202 degrees
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #10 · (Edited)
i pulled the waterpump today the fing impeller fell off pep boys sucks im goin oem my housing is scarred should i replace i dont want it to cavitate
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
i have a vaccume bleeder so i should not have air thanks everyone for the input
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #15 ·
pepboys/bosch replaced the waterpump,the housing ,6 gallons 50/50 coolant and 200.00 to re install the part im happy truck is running great
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top